summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2005-02-07 13:19:45 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2005-02-07 13:19:45 +0000
commit9d0e65ed92ad0fd928b7b7dc900f88cd5f203208 (patch)
tree1164b2dfa512f6adea8e96efecfacad866f225b1 /cpukit/configure.ac
parent2005-02-07 Ralf Corsepius <ralf.corsepius@rtems.org> (diff)
downloadrtems-9d0e65ed92ad0fd928b7b7dc900f88cd5f203208.tar.bz2
2005-02-07 Ralf Corsepius <ralf.corsepius@rtems.org>
* Makefile.am: Add include/rtems/tar.h. Merge-in header rules from libmisc/Makefile.am * libmisc/Makefile.am: Remove header rules. Remove lib-specific CPPFLAGS. * configure.ac: Add checks for <tar.h>
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index 04da0763a4..39c969eeec 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -91,6 +91,7 @@ AC_CHECK_FUNCS([isascii fileno])
## Check if the installed toolchain has these headers
AC_CHECK_HEADER([stdint.h])
AC_CHECK_HEADER([inttypes.h])
+AC_CHECK_HEADER([tar.h])
## if using newlib, we provide stdint.h and inttypes.h
AM_CONDITIONAL([RTEMS_PROVIDES_STDINT_H],[test x"${RTEMS_USE_NEWLIB}" = xyes])
@@ -101,6 +102,10 @@ AS_IF([test x"${RTEMS_USE_NEWLIB}" = xyes],
[RTEMS_USES_STDINT_H=yes],
[RTEMS_USES_STDINT_H=$ac_cv_header_stdint_h])
+AS_IF([test x"${RTEMS_USE_NEWLIB}" = xyes],
+[RTEMS_USES_TAR_H=yes],
+[RTEMS_USES_TAR_H=$ac_cv_header_tar_h])
+
AS_IF([test x"${RTEMS_CPU}" = x"unix"],[
## FIXME: This check is doubtful
AS_IF([test "$HAS_MP" = "yes"],
@@ -176,6 +181,11 @@ RTEMS_CPUOPT([RTEMS_USES_STDINT_H],
[1],
[if RTEMS uses stdint.h])
+RTEMS_CPUOPT([RTEMS_USES_TAR_H],
+ [test x"${RTEMS_USES_TAR_H}" = x"yes"],
+ [1],
+ [if RTEMS uses tar.h])
+
RTEMS_CPUOPT([RTEMS_VERSION],
[true],
["]_RTEMS_VERSION["],