summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-07-08 07:49:08 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-07-08 07:49:08 +0000
commit92ed8c28f432ecb1d3018a72f3202c2ad4536f16 (patch)
tree8ebc725c23a5f5d2877c2ebc27149aca37b2b26d /cpukit/configure.ac
parent2003-07-08 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-92ed8c28f432ecb1d3018a72f3202c2ad4536f16.tar.bz2
2003-07-08 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.ac: Merge-in ada/configure.ac. * Makefile.am: Add ada to SUBDIRS.
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac15
1 files changed, 9 insertions, 6 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index 34da6bf121..92c67de3a2 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -30,6 +30,9 @@ RTEMS_PROG_CC_FOR_TARGET([-ansi -fasm])
RTEMS_CANONICALIZE_TOOLS
AC_PROG_RANLIB
+# FIXME: For the moment, no reason to check for ada
+# RTEMS_PROG_GNAT
+
RTEMS_CHECK_NEWLIB
RTEMS_CHECK_MULTIPROCESSING
@@ -90,12 +93,6 @@ AC_ARG_ENABLE([ada],
*) AC_MSG_ERROR([bad value ${enable_ada} for --enable-ada]) ;;
esac],[enable_ada=no])
-AS_IF([test x"$enable_ada" = x"yes"],[
- AS_IF([test x"$HAS_POSIX_API" = x"yes"],[
- AC_CONFIG_SUBDIRS([ada])
- ])
-])
-
RTEMS_DEFINE_POSIX_API
RTEMS_DEFINE_ITRON_API
RTEMS_DEFINE_MULTIPROCESSING
@@ -144,6 +141,9 @@ AS_IF([test x"${enable_multilib}" = x"yes"],[
AC_CONFIG_SUBDIRS([libmisc])
+AM_CONDITIONAL(RTEMS_ADA,[test x"$enable_ada" = x"yes" \
+ && test x"$HAS_POSIX_API" = x"yes"])
+
# Explicitly list all Makefiles here
AC_CONFIG_FILES([Makefile
include/Makefile
@@ -153,4 +153,7 @@ score/Makefile
score/cpu/Makefile
wrapup/Makefile
])
+
+AC_CONFIG_FILES([ada/Makefile])
+
AC_OUTPUT