summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2018-07-03 11:50:53 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2018-07-05 07:10:04 +0200
commit77fbbd620f3eb4aa54cccd3491a2feff955f7822 (patch)
treecf96defcbac36450208907795f5fc4963ea57361 /cpukit/configure.ac
parentriscv: Fix fcsr initialization (diff)
downloadrtems-77fbbd620f3eb4aa54cccd3491a2feff955f7822.tar.bz2
posix: Check for new <pthread.h> prototypes
Update #3342. Update #3343.
Diffstat (limited to '')
-rw-r--r--cpukit/configure.ac23
1 files changed, 23 insertions, 0 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index 235241643e..0361128e1d 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -115,6 +115,29 @@ RTEMS_CHECK_FUNC([pthread_getattr_np],[
#define _GNU_SOURCE
#include <pthread.h>])
+AC_LANG_PUSH(C)
+AC_MSG_CHECKING([for pthread_mutex_getprioceiling(const pthread_mutex_t *, ...)])
+AC_COMPILE_IFELSE([AC_LANG_SOURCE([
+#include <pthread.h>
+int pthread_mutex_getprioceiling(const pthread_mutex_t *__restrict, int *);
+])],[
+AC_MSG_RESULT([yes])
+AC_DEFINE(HAVE_PTHREAD_MUTEX_GETCEILING_CONST, [], [pthread_mutex_getprioceiling(const pthread_mutex_t *, ...)])
+],[
+AC_MSG_RESULT([no])
+])
+AC_MSG_CHECKING([for pthread_setschedparam(..., const struct sched_param *)])
+AC_COMPILE_IFELSE([AC_LANG_SOURCE([
+#include <pthread.h>
+int pthread_setschedparam(pthread_t, int, const struct sched_param *);
+])],[
+AC_MSG_RESULT([yes])
+AC_DEFINE(HAVE_PTHREAD_SETSCHEDPARAM_CONST, [], [pthread_setschedparam(..., const struct sched_param *)])
+],[
+AC_MSG_RESULT([no])
+])
+AC_LANG_POP(C)
+
# Mandated by POSIX, not declared in some versions of newlib.
AC_CHECK_DECLS([getrusage],,,[#include sys/resource.h])