summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-10-21 14:51:01 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-10-21 14:51:01 +0000
commit5b2e19988f6d1893543c21003859ee66d30faa58 (patch)
tree4789975cdf62e6b082e4feef3e562c8e5a6ebfe8 /cpukit/configure.ac
parent2003-10-21 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-5b2e19988f6d1893543c21003859ee66d30faa58.tar.bz2
2003-10-21 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* aclocal/check-multiprocessing.m4: Add m4-quotes. Remove RTEMS_CHECK_CPU. * aclocal/check-itron.m4: Add m4-quotes. Require RTEMS_CANONICAL_TARGET_CPU instead of RTEMS_CHECK_CPU. * aclocal/check-networking.m4: Add m4-quotes. Require RTEMS_CANONICAL_TARGET_CPU instead of RTEMS_CHECK_CPU. * aclocal/check-cpu.m4: Remove. * aclocal/canonical-target-name.m4: Add m4-quotes. * configure.ac: Merge-in former aclocal/check-cpu.m4.
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index aa34e14038..da56d50f67 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -23,7 +23,14 @@ RTEMS_ENABLE_NETWORKING
RTEMS_ENV_RTEMSCPU
RTEMS_CHECK_RTEMS_DEBUG
-RTEMS_CHECK_CPU
+# Is this a supported CPU?
+AC_MSG_CHECKING([if cpu $RTEMS_CPU is supported])
+if test -d "$srcdir/score/cpu/$RTEMS_CPU"; then
+ AC_MSG_RESULT(yes)
+else
+ AC_MSG_ERROR(no)
+fi
+
RTEMS_CANONICAL_HOST
RTEMS_PROG_CC_FOR_TARGET([-ansi -fasm])