summaryrefslogtreecommitdiffstats
path: root/cpukit/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2010-06-13 03:36:58 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2010-06-13 03:36:58 +0000
commitde93598d19d25f3fa0413c286290aa1f5573bdb4 (patch)
tree2185f0bfff7a17fe26af7da06c45912feb88704d /cpukit/configure.ac
parent2010-06-13 Ralf Corsépius <ralf.corsepius@rtems.org> (diff)
downloadrtems-de93598d19d25f3fa0413c286290aa1f5573bdb4.tar.bz2
2010-06-13 Ralf Corsépius <ralf.corsepius@rtems.org>
* include/rtems/tar.h, libcsupport/include/tar.h: Remove. * configure.ac: Require toolchain to provide tar.h. * libfs/src/imfs/imfs_load_tar.c, libmisc/untar/untar.h: Use <tar.h> instead of <rtems/tar.h>.
Diffstat (limited to 'cpukit/configure.ac')
-rw-r--r--cpukit/configure.ac13
1 files changed, 4 insertions, 9 deletions
diff --git a/cpukit/configure.ac b/cpukit/configure.ac
index 18e5d21238..f7b59ecd2e 100644
--- a/cpukit/configure.ac
+++ b/cpukit/configure.ac
@@ -84,6 +84,10 @@ AS_IF([test x"${ac_cv_header_errno_h}" != xyes],
AS_IF([test x"${ac_cv_header_sched_h}" != xyes],
[AC_MSG_ERROR([Required header sched.h not found])])
+## error out if libc doesn't provide tar.h
+AS_IF([test x"${ac_cv_header_tar_h}" != xyes],
+[AC_MSG_ERROR([Required header tar.h not found])])
+
AC_HEADER_STDBOOL
AS_IF([test x"${ac_cv_header_stdbool_h}" != xyes],
[AC_MSG_ERROR([No sufficient stdbool.h found])])
@@ -112,10 +116,6 @@ RTEMS_CHECK_POSIX_API
RTEMS_CHECK_ITRON_API
RTEMS_CHECK_NETWORKING
-AS_IF([test x"${RTEMS_USE_NEWLIB}" = xyes],
-[RTEMS_USES_TAR_H=yes],
-[RTEMS_USES_TAR_H=$ac_cv_header_tar_h])
-
rtems_major=`echo _RTEMS_VERSION | sed "s/\..*//"`
rtems_minor=`echo _RTEMS_VERSION | sed "s/[[0-9]][[0-9]]*\.//;s/\..*//"`
rtems_revision=`echo _RTEMS_VERSION | sed "s/[[0-9]][[0-9]]*\.//;s/[[0-9]][[0-9]]*\.//;s/\..*//"`
@@ -152,11 +152,6 @@ RTEMS_CPUOPT([RTEMS_NETWORKING],
[1],
[if networking is enabled])
-RTEMS_CPUOPT([RTEMS_USES_TAR_H],
- [test x"${RTEMS_USES_TAR_H}" = x"yes"],
- [1],
- [if RTEMS uses tar.h])
-
RTEMS_CPUOPT([RTEMS_VERSION],
[true],
["]_RTEMS_VERSION["],