summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2021-09-03 17:14:19 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2021-09-03 17:14:19 +0200
commitfbd0a3cec3096d8fe283c3ff05ebb5c0aafc95d9 (patch)
tree423274f5da7867f6b0065887fabd4706dce920d2 /cpukit/Makefile.am
parentscore: Document thread queue operations (diff)
downloadrtems-fbd0a3cec3096d8fe283c3ff05ebb5c0aafc95d9.tar.bz2
score: Move _Thread_Dispatch()
The _Thread_Dispatch() function was customized over time and now the work is done by _Thread_Do_dispatch() and specialized wrappers. The plain _Thread_Dispatch() is now only used in some CPU ports. Move it to a separate file to avoid dead code in the general. Change license to BSD-2-Clause according to file history and re-licensing agreement. Update #3053.
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index 1afac8f7dc..93100b5e5a 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -966,6 +966,7 @@ librtemscpu_a_SOURCES += score/src/threadhandler.c
librtemscpu_a_SOURCES += score/src/threadinitialize.c
librtemscpu_a_SOURCES += score/src/threadidledefault.c
librtemscpu_a_SOURCES += score/src/threadloadenv.c
+librtemscpu_a_SOURCES += score/src/threadplaindispatch.c
librtemscpu_a_SOURCES += score/src/threadrestart.c
librtemscpu_a_SOURCES += score/src/threadselfid.c
librtemscpu_a_SOURCES += score/src/threadsetstate.c