summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2020-09-30 11:31:58 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2020-10-01 19:05:33 +0200
commitf2185d109930fb5db31a5c228a3f46178072f270 (patch)
tree166d29b19bcf7ff01b4368f351e3fab52b750c19 /cpukit/Makefile.am
parentrtems: Canonicalize name and id checks (diff)
downloadrtems-f2185d109930fb5db31a5c228a3f46178072f270.tar.bz2
Decouple the C Program Heap initialization
Before this patch RTEMS_Malloc_Initialize() had a fixed dependency on _Workspace_Area. Introduce _Workspace_Malloc_initializer to have this dependency only if CONFIGURE_UNIFIED_WORK_AREAS is defined by the application configuration.
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am3
1 files changed, 3 insertions, 0 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index 2c35354e66..1f9124e175 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -176,6 +176,7 @@ librtemscpu_a_SOURCES += libcsupport/src/mallocdirtydefault.c
librtemscpu_a_SOURCES += libcsupport/src/mallocextenddefault.c
librtemscpu_a_SOURCES += libcsupport/src/mallocfreespace.c
librtemscpu_a_SOURCES += libcsupport/src/mallocgetheapptr.c
+librtemscpu_a_SOURCES += libcsupport/src/mallocheap.c
librtemscpu_a_SOURCES += libcsupport/src/mallocinfo.c
librtemscpu_a_SOURCES += libcsupport/src/malloc_initialize.c
librtemscpu_a_SOURCES += libcsupport/src/_malloc_r.c
@@ -1025,6 +1026,8 @@ librtemscpu_a_SOURCES += score/src/interr.c
librtemscpu_a_SOURCES += score/src/isr.c
librtemscpu_a_SOURCES += score/src/wkspace.c
librtemscpu_a_SOURCES += score/src/wkspaceisunifieddefault.c
+librtemscpu_a_SOURCES += score/src/wkspacemallocinitdefault.c
+librtemscpu_a_SOURCES += score/src/wkspacemallocinitunified.c
librtemscpu_a_SOURCES += score/src/wkstringduplicate.c
librtemscpu_a_SOURCES += score/src/iobase64.c
librtemscpu_a_SOURCES += score/src/ioprintf.c