summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2005-01-27 06:42:37 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2005-01-27 06:42:37 +0000
commite18080ab06ebce8a07fe54e601ce200908ac6ce2 (patch)
tree7828c04c22e76ab8c9277c47c4f157acd9512c33 /cpukit/Makefile.am
parent2005-01-27 Ralf Corsepius <ralf.corsepius@rtems.org> (diff)
downloadrtems-e18080ab06ebce8a07fe54e601ce200908ac6ce2.tar.bz2
2005-01-27 Ralf Corsepius <ralf.corsepius@rtems.org>
* libcsupport/include/tar.h: New (SUSv3). * Makefile.am: Integrate newlib-specific headers. Add libcsupport/include/tar.h. * libcsupport/Makefile.am: Remove newlib-specific headers.
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am66
1 files changed, 66 insertions, 0 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index 99a2912cdc..27cd443ac6 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -46,6 +46,21 @@ include_HEADERS += backward/itron.h
endif
endif
+if NEWLIB
+include_sysdir = $(includedir)/sys
+include_sys_HEADERS =
+
+include_HEADERS += libcsupport/include/stdint.h
+include_HEADERS += libcsupport/include/inttypes.h
+include_HEADERS += libcsupport/include/tar.h
+
+include_sys_HEADERS += libcsupport/include/sys/ioccom.h \
+ libcsupport/include/sys/filio.h libcsupport/include/sys/ioctl.h \
+ libcsupport/include/sys/sockio.h libcsupport/include/sys/ttycom.h \
+ libcsupport/include/sys/termios.h libcsupport/include/sys/utsname.h \
+ libcsupport/include/sys/cdefs.h
+endif
+
include_rtemsdir = $(includedir)/rtems
include_rtems_HEADERS = include/rtems/bspIo.h include/rtems/userenv.h \
include/rtems/fs.h include/rtems/pci.h include/rtems/stdint.h \
@@ -151,6 +166,57 @@ PREINSTALL_FILES += $(PROJECT_INCLUDE)/itron.h
endif
endif
+if NEWLIB
+$(PROJECT_INCLUDE)/sys/$(dirstamp):
+ @$(mkdir_p) $(PROJECT_INCLUDE)/sys
+ @: > $(PROJECT_INCLUDE)/sys/$(dirstamp)
+PREINSTALL_DIRS += $(PROJECT_INCLUDE)/sys/$(dirstamp)
+
+$(PROJECT_INCLUDE)/stdint.h: libcsupport/include/stdint.h $(PROJECT_INCLUDE)/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/stdint.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/stdint.h
+
+$(PROJECT_INCLUDE)/inttypes.h: libcsupport/include/inttypes.h $(PROJECT_INCLUDE)/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/inttypes.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/inttypes.h
+
+$(PROJECT_INCLUDE)/tar.h: libcsupport/include/tar.h $(PROJECT_INCLUDE)/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/tar.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/tar.h
+
+$(PROJECT_INCLUDE)/sys/ioccom.h: libcsupport/include/sys/ioccom.h $(PROJECT_INCLUDE)/sys/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/sys/ioccom.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/sys/ioccom.h
+
+$(PROJECT_INCLUDE)/sys/filio.h: libcsupport/include/sys/filio.h $(PROJECT_INCLUDE)/sys/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/sys/filio.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/sys/filio.h
+
+$(PROJECT_INCLUDE)/sys/ioctl.h: libcsupport/include/sys/ioctl.h $(PROJECT_INCLUDE)/sys/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/sys/ioctl.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/sys/ioctl.h
+
+$(PROJECT_INCLUDE)/sys/sockio.h: libcsupport/include/sys/sockio.h $(PROJECT_INCLUDE)/sys/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/sys/sockio.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/sys/sockio.h
+
+$(PROJECT_INCLUDE)/sys/ttycom.h: libcsupport/include/sys/ttycom.h $(PROJECT_INCLUDE)/sys/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/sys/ttycom.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/sys/ttycom.h
+
+$(PROJECT_INCLUDE)/sys/termios.h: libcsupport/include/sys/termios.h $(PROJECT_INCLUDE)/sys/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/sys/termios.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/sys/termios.h
+
+$(PROJECT_INCLUDE)/sys/utsname.h: libcsupport/include/sys/utsname.h $(PROJECT_INCLUDE)/sys/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/sys/utsname.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/sys/utsname.h
+
+$(PROJECT_INCLUDE)/sys/cdefs.h: libcsupport/include/sys/cdefs.h $(PROJECT_INCLUDE)/sys/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/sys/cdefs.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/sys/cdefs.h
+endif
+
$(PROJECT_INCLUDE)/rtems/$(dirstamp):
@$(mkdir_p) $(PROJECT_INCLUDE)/rtems
@: > $(PROJECT_INCLUDE)/rtems/$(dirstamp)