summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2021-04-20 08:41:00 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2021-04-20 19:18:23 +0200
commitd8a5e140ec44a5e45cf82d3759a339e9dedced56 (patch)
treeb159ba580e893b698c029dcd586aa358734bbdc8 /cpukit/Makefile.am
parentRemove superfluous <rtems/score/wkspace.h> includes (diff)
downloadrtems-d8a5e140ec44a5e45cf82d3759a339e9dedced56.tar.bz2
libcsupport: Move rtems_calloc()
Move rtems_calloc() since it only depends on rtems_malloc(). This may make it easier to customize the heap allocator. Change licence to BSD-2-Clause according to file history. Update #3053.
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index d6b636bf2a..a8cce3c287 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -213,6 +213,7 @@ librtemscpu_a_SOURCES += libcsupport/src/realpath.c
librtemscpu_a_SOURCES += libcsupport/src/_rename_r.c
librtemscpu_a_SOURCES += libcsupport/src/resource_snapshot.c
librtemscpu_a_SOURCES += libcsupport/src/rmdir.c
+librtemscpu_a_SOURCES += libcsupport/src/rtemscalloc.c
librtemscpu_a_SOURCES += libcsupport/src/rtems_heap_extend.c
librtemscpu_a_SOURCES += libcsupport/src/rtems_heap_extend_via_sbrk.c
librtemscpu_a_SOURCES += libcsupport/src/rtems_heap_greedy.c