summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2020-04-09 15:17:46 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2020-08-31 17:30:17 +0200
commitd8172209b3f1288761ba410f52b89adeb56394fe (patch)
treeaff73c4b9cc562a3307231749d449fd439c83897 /cpukit/Makefile.am
parentscore: Use _Freechain_Push() (diff)
downloadrtems-d8172209b3f1288761ba410f52b89adeb56394fe.tar.bz2
score: Add _Stack_Allocator_do_initialize()
Do the stack allocator initialization and sanity check only if a user-provided stack allocator was configured. This avoids a dependency of _Thread_Handler_initialization() on the stack allocator. Update #3959.
Diffstat (limited to '')
-rw-r--r--cpukit/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index 4b794c5c29..4ba3fd48d1 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -932,6 +932,7 @@ librtemscpu_a_SOURCES += score/src/schedulercbssetparameters.c
librtemscpu_a_SOURCES += score/src/schedulercbsreleasejob.c
librtemscpu_a_SOURCES += score/src/schedulercbsunblock.c
librtemscpu_a_SOURCES += score/src/stackallocator.c
+librtemscpu_a_SOURCES += score/src/stackallocatorinit.c
librtemscpu_a_SOURCES += score/src/pheapallocate.c
librtemscpu_a_SOURCES += score/src/pheapextend.c
librtemscpu_a_SOURCES += score/src/pheapfree.c