summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2018-11-06 13:04:11 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2018-11-07 07:52:55 +0100
commitd1f7204649ff7c8bed36eab5af20c1a108af8b14 (patch)
treed61f8e715001e2e7538186c142f0c3d04a6fe1f8 /cpukit/Makefile.am
parentspconfig02: Check object methods in default config (diff)
downloadrtems-d1f7204649ff7c8bed36eab5af20c1a108af8b14.tar.bz2
config: Fix CONFIGURE_DISABLE_NEWLIB_REENTRANCY
Move the __getreent() variant using the global reentrancy structure to librtemscpu.a. This avoids a definition of __getreent() in the configuration module if CONFIGURE_DISABLE_NEWLIB_REENTRANCY is defined. This avoids all the dependencies which would be exposed by a reference to the global reentrancy structure. This change is only possible since the default configuration moved to librtemsdefaultconfig.a recently.
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index b0d9088d44..786222bd81 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -151,6 +151,7 @@ librtemscpu_a_SOURCES += libcsupport/src/__getpid.c
librtemscpu_a_SOURCES += libcsupport/src/getpid.c
librtemscpu_a_SOURCES += libcsupport/src/getppid.c
librtemscpu_a_SOURCES += libcsupport/src/getpwent.c
+librtemscpu_a_SOURCES += libcsupport/src/getreentglobal.c
librtemscpu_a_SOURCES += libcsupport/src/getrusage.c
librtemscpu_a_SOURCES += libcsupport/src/__gettod.c
librtemscpu_a_SOURCES += libcsupport/src/getuid.c