summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2020-08-07 20:30:39 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2020-08-11 08:03:47 +0200
commitc1354f05149a9290d61ff9acf39129df46d5eac5 (patch)
tree9d39aa0f455d86f5aa1b2b2f66f616f08c3038d7 /cpukit/Makefile.am
parentlibtest: Constify (diff)
downloadrtems-c1354f05149a9290d61ff9acf39129df46d5eac5.tar.bz2
libtest: Add T_thread_switch_record()
Add support to record thread switch events. This can be used to check that a blocking operation results in the expected sequence of thread switches. Update #3199.
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index 75e119ea3c..aa1fe5fc16 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -1874,6 +1874,7 @@ librtemstest_a_SOURCES += libtest/t-test-rtems-measure.c
librtemstest_a_SOURCES += libtest/t-test-rtems-objs.c
librtemstest_a_SOURCES += libtest/t-test-rtems-posix-keys.c
librtemstest_a_SOURCES += libtest/t-test-time.c
+librtemstest_a_SOURCES += libtest/t-test-thread-switch.c
project_lib_LIBRARIES += libftpd.a