summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2015-03-30 22:19:17 +1100
committerChris Johns <chrisj@rtems.org>2015-03-31 17:04:43 +1100
commita300920de12ed9c14f2637961285588413cab6fb (patch)
treee7a5218ccc0e916dac2769767c8c159a2becd878 /cpukit/Makefile.am
parentTMS570: Add board reset code to bsp_reset (diff)
downloadrtems-a300920de12ed9c14f2637961285588413cab6fb.tar.bz2
libmisc/shell: Add the rtrace command for buffered tracing support.
The rtrace command interfaces to the RTEMS Trace Linker's trace buffering data allowing users to capture and report trace data.
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index 10b59db111..7df116ce07 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -172,6 +172,11 @@ include_rtems_HEADERS += libmisc/capture/capture.h
include_rtems_HEADERS += libmisc/capture/capture-cli.h
include_rtems_HEADERS += libmisc/capture/captureimpl.h
+# tracing headers
+include_rtems_tracedir = $(include_rtemsdir)/trace
+include_rtems_trace_HEADERS =
+include_rtems_trace_HEADERS += libmisc/capture/rtems-trace-buffer-vars.h
+
## cpuuse
include_rtems_HEADERS += libmisc/cpuuse/cpuuse.h