summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2020-04-03 09:47:21 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2020-04-03 15:48:58 +0200
commit8e80876bdd54e36fb668eee655eec1dd588daf13 (patch)
tree4bd351727c3be15a96035ac1a790f7cfab7a5d8d /cpukit/Makefile.am
parentbsp/shared/clock: Reset Clock_driver_isrs to correct value (diff)
downloadrtems-8e80876bdd54e36fb668eee655eec1dd588daf13.tar.bz2
score: Fix _ISR_Stack_area_end
The _ISR_Stack_area_begin and _ISR_Stack_area_end symbols are in different sections. They must have the same alignment, otherwise the following linker directive could separate them: *(SORT_BY_ALIGNMENT (SORT_BY_NAME (.rtemsstack*))) Update #3799.
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index 3af69bd615..1486a4156f 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -1014,6 +1014,7 @@ librtemscpu_a_SOURCES += score/src/chainnodecount.c
librtemscpu_a_SOURCES += score/src/debugisthreaddispatchingallowed.c
librtemscpu_a_SOURCES += score/src/interr.c
librtemscpu_a_SOURCES += score/src/isr.c
+librtemscpu_a_SOURCES += score/src/isrstackareaend.c
librtemscpu_a_SOURCES += score/src/wkspace.c
librtemscpu_a_SOURCES += score/src/wkspaceisunifieddefault.c
librtemscpu_a_SOURCES += score/src/wkstringduplicate.c