summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2021-05-17 16:39:52 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2021-05-17 17:29:36 +0200
commit815a94326c35b34fc3283a575eece11e972405cf (patch)
treeb1bbe17dc0f750702a34e8763837beedb4ba812d /cpukit/Makefile.am
parentbsps/imxrt: Enable DMA clock (diff)
downloadrtems-815a94326c35b34fc3283a575eece11e972405cf.tar.bz2
posix: Move clock_nanosleep()
Move clock_nanosleep() to a separate file to avoid a dependency on errno which pulls in the Newlib reentrancy support. This is an issue since most parts which are pulled in cannot be garbage collected by the linker due to the system initialization linker set.
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index 0178d5d82a..a5f3a9665f 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -490,6 +490,7 @@ librtemscpu_a_SOURCES += posix/src/cleanuppush.c
librtemscpu_a_SOURCES += posix/src/clockgetcpuclockid.c
librtemscpu_a_SOURCES += posix/src/clockgetres.c
librtemscpu_a_SOURCES += posix/src/clockgettime.c
+librtemscpu_a_SOURCES += posix/src/clocknanosleep.c
librtemscpu_a_SOURCES += posix/src/clocksettime.c
librtemscpu_a_SOURCES += posix/src/condattrdestroy.c
librtemscpu_a_SOURCES += posix/src/condattrgetclock.c