summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2021-05-17 16:55:15 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2021-05-17 17:30:39 +0200
commit80b3c938ce9798997c59cc102fb6738475f6fe32 (patch)
tree2d3d69e64865278812acf569fed5468624b07f85 /cpukit/Makefile.am
parentposix: Use RTEMS_POSIX_API in clock_nanosleep() (diff)
downloadrtems-80b3c938ce9798997c59cc102fb6738475f6fe32.tar.bz2
score: Move _Thread_queue_Queue_get_name_and_id()
Move this diagnostic function to a separate file since it does not provide a core function of the system. Change license to BSD-2-Clause according to file history and re-licensing agreement. Update #3053.
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index a5f3a9665f..db025ac6f8 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -985,6 +985,7 @@ librtemscpu_a_SOURCES += score/src/threadqenqueue.c
librtemscpu_a_SOURCES += score/src/threadqextractwithproxy.c
librtemscpu_a_SOURCES += score/src/threadqfirst.c
librtemscpu_a_SOURCES += score/src/threadqflush.c
+librtemscpu_a_SOURCES += score/src/threadqgetnameandid.c
librtemscpu_a_SOURCES += score/src/threadqops.c
librtemscpu_a_SOURCES += score/src/threadqtimeout.c
librtemscpu_a_SOURCES += score/src/timespecaddto.c