summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-09-24 08:11:33 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-09-24 08:11:33 +0000
commit71e66df3ce4643964d4baffad6bb2426df9007b4 (patch)
tree68b3b6bbece7e8e1c2dc71ff21cd49d9c39c19f2 /cpukit/Makefile.am
parent2003-09-24 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-71e66df3ce4643964d4baffad6bb2426df9007b4.tar.bz2
2003-09-24 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Merge-in include/Makefile.am. * include/Makefile.am: Remove. * configure.ac: Reflect having removed include/Makefile.am and librpc/include/Makefile.am.
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am22
1 files changed, 21 insertions, 1 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index 9a41ac6cad..9512ddda6d 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -6,7 +6,7 @@ ACLOCAL_AMFLAGS = -I aclocal
include $(top_srcdir)/automake/multilib.am
-SUBDIRS = . include ada score rtems sapi posix itron
+SUBDIRS = . ada score rtems sapi posix itron
SUBDIRS += libcsupport libblock libfs
SUBDIRS += libnetworking librpc
SUBDIRS += libmisc
@@ -19,6 +19,26 @@ preinstall-stamp:
touch preinstall-stamp
CLEANFILES = preinstall-stamp
+$(PROJECT_INCLUDE)/%.h: include/%.h
+ $(INSTALL_DATA) $< $@
+
+$(PROJECT_INCLUDE):
+ @$(mkinstalldirs) $@
+
+$(PROJECT_INCLUDE)/rtems:
+ @$(mkinstalldirs) $@
+
+PREINSTALL_FILES = $(PROJECT_INCLUDE)
+
+include_rtemsdir = $(includedir)/rtems
+include_rtems_HEADERS = include/rtems/bspIo.h include/rtems/userenv.h \
+ include/rtems/fs.h include/rtems/stdint.h
+
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems \
+ $(include_rtems_HEADERS:include/%.h=$(PROJECT_INCLUDE)/%.h)
+
+all-local: $(PREINSTALL_FILES)
+
AUTOMAKE_FILES = automake/compile.am automake/lib.am automake/local.am \
automake/multilib.am automake/subdirs.am
EXTRA_DIST = $(AUTOMAKE_FILES)