summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2019-02-02 15:09:53 +1100
committerChris Johns <chrisj@rtems.org>2019-02-09 10:06:34 +1100
commit6c9f0176a916cdbe88e04417e7aa1405d80c500f (patch)
tree1846dd800a123e682f15e49a893426a9a6a064c4 /cpukit/Makefile.am
parentlibdl: Add support for large memory programs (diff)
downloadrtems-6c9f0176a916cdbe88e04417e7aa1405d80c500f.tar.bz2
libdl: Add powerpc large memory and small data support.
- Add support for architecure sections that can be handled by the architecture back end. - Add trampoline/fixup support for PowerPC. This means the PowerPC now supports large memory loading of applications. - Add a bit allocator to manage small block based regions of memory. - Add small data (sdata/sbss) support for the PowerPC. The support makes the linker allocated small data region of memory a global resource available to libdl loaded object files. Updates #3687 Updates #3685
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index 8ea7cbbfb0..51ab18ca05 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -1141,6 +1141,7 @@ librtemscpu_a_SOURCES += libdl/rap-shell.c
librtemscpu_a_SOURCES += libdl/rtl-allocator.c
librtemscpu_a_SOURCES += libdl/rtl-alloc-heap.c
librtemscpu_a_SOURCES += libdl/rtl-archive.c
+librtemscpu_a_SOURCES += libdl/rtl-bit-alloc.c
librtemscpu_a_SOURCES += libdl/rtl.c
librtemscpu_a_SOURCES += libdl/rtl-chain-iterator.c
librtemscpu_a_SOURCES += libdl/rtl-debugger.c