summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2018-09-13 06:35:03 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2018-10-09 13:26:47 +0200
commit690718ab37acaaf43c22cd839ebde2a7042e007b (patch)
treecc44c45a235952cd5aaa00253977338d7913e891 /cpukit/Makefile.am
parentbuild: Merge dev/Makefile.am (diff)
downloadrtems-690718ab37acaaf43c22cd839ebde2a7042e007b.tar.bz2
build: Merge ftpd/Makefile.am
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am14
1 files changed, 13 insertions, 1 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index 6a5ef61813..7a3e8319ff 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -3,6 +3,9 @@ ACLOCAL_AMFLAGS = -I aclocal
include $(top_srcdir)/automake/compile.am
include $(top_srcdir)/automake/multilib.am
+project_lib_LIBRARIES =
+TMPINSTALL_FILES =
+
noinst_LIBRARIES = libcpukit.a
libcpukit_a_SOURCES =
@@ -110,11 +113,20 @@ _SUBDIRS += wrapup
# other libraries
_SUBDIRS += zlib
-_SUBDIRS += ftpd
_SUBDIRS += telnetd
_SUBDIRS += pppd
_SUBDIRS += mghttpd
+project_lib_LIBRARIES += libftpd.a
+
+$(PROJECT_LIB)/libftpd.a: libftpd.a
+ $(INSTALL_DATA) $< $(PROJECT_LIB)/libftpd.a
+TMPINSTALL_FILES += $(PROJECT_LIB)/libftpd.a
+
+libftpd_a_SOURCES =
+libftpd_a_SOURCES += ftpd/ftpd.c
+libftpd_a_SOURCES += ftpd/ftpd-init.c
+
include $(top_srcdir)/automake/subdirs.am
include $(top_srcdir)/automake/local.am
include $(srcdir)/headers.am