summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel@rtems.org>2019-10-02 16:49:00 -0500
committerJoel Sherrill <joel@rtems.org>2019-10-08 14:25:41 -0500
commit667501a314ba75f80f1c13c6b43dd35d0a00efd1 (patch)
treeec786d34150d19f7aac04b2653fa356c6a696de2 /cpukit/Makefile.am
parenttermios04/init.c: Remove dead copy of change_iflag() (diff)
downloadrtems-667501a314ba75f80f1c13c6b43dd35d0a00efd1.tar.bz2
termios: Add Capability to Generate SIGINTR and SIGQUIT
This patch adds the ability for termios to send SIGINTR on receipt of VINTR and SIGQUIT for VKILL and return -1/EINTR from read() on a termios channel. Importantly, this patch does not alter the default behavior or force POSIX signal code in just because termios is used. The application must explicitly enable the POSIX behavior of generating a signal upon receipt of these characters. This is discussed in the POSIX standard: https://pubs.opengroup.org/onlinepubs/9699919799/basedefs/V1_chap11.html Closes #3800.
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index 01ee40980f..7698fe5482 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -250,6 +250,7 @@ librtemscpu_a_SOURCES += libcsupport/src/termios_baudtable.c
librtemscpu_a_SOURCES += libcsupport/src/termios.c
librtemscpu_a_SOURCES += libcsupport/src/termiosinitialize.c
librtemscpu_a_SOURCES += libcsupport/src/termios_num2baud.c
+librtemscpu_a_SOURCES += libcsupport/src/termios_posix_isig_handler.c
librtemscpu_a_SOURCES += libcsupport/src/termios_setbestbaud.c
librtemscpu_a_SOURCES += libcsupport/src/termios_setinitialbaud.c
librtemscpu_a_SOURCES += libcsupport/src/__times.c