summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2020-11-19 16:07:04 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2020-11-26 11:10:22 +0100
commit657e30c135f22c4448cfd13f8113b23e72776dad (patch)
tree3673a8df391a0fb170d4cbffb8e1d05821771aa2 /cpukit/Makefile.am
parentAvoid INTERNAL_ERROR_RTEMS_INIT_TASK_ENTRY_IS_NULL (diff)
downloadrtems-657e30c135f22c4448cfd13f8113b23e72776dad.tar.bz2
config: CONFIGURE_INIT_TASK_CONSTRUCT_STORAGE_SIZE
In order to better support applications which use the new rtems_task_construct() directive add the CONFIGURE_INIT_TASK_CONSTURCT_STORAGE_SIZE configuration option. If this option is specified, then the Classic API initialization task is constructed with rtems_task_construct(). Update #4181.
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index 8c7f9c1ed4..b7435d7eb6 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -790,6 +790,7 @@ librtemscpu_a_SOURCES += rtems/src/statustoerrno.c
librtemscpu_a_SOURCES += rtems/src/systemeventreceive.c
librtemscpu_a_SOURCES += rtems/src/systemeventsend.c
librtemscpu_a_SOURCES += rtems/src/taskconstruct.c
+librtemscpu_a_SOURCES += rtems/src/taskconstructuser.c
librtemscpu_a_SOURCES += rtems/src/taskcreate.c
librtemscpu_a_SOURCES += rtems/src/taskdelete.c
librtemscpu_a_SOURCES += rtems/src/taskexit.c