summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2005-02-08 15:02:25 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2005-02-08 15:02:25 +0000
commit6265b8306047c800ac84514601ffd05322db79d4 (patch)
tree81d3a31146f2767fc15300eca93fc217e45e0e06 /cpukit/Makefile.am
parentNew. (diff)
downloadrtems-6265b8306047c800ac84514601ffd05322db79d4.tar.bz2
Split preinstallation rules in to separate files (preinstall.am).
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am318
1 files changed, 13 insertions, 305 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index 6f7b2e15b2..8c4d202c6c 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -15,15 +15,23 @@ SUBDIRS += httpd
SUBDIRS += ftpd
SUBDIRS += wrapup
-noinst_DATA = preinstall-stamp
+CLEANFILES =
+DISTCLEANFILES =
+noinst_DATA = preinstall-stamp
preinstall-stamp:
$(MAKE) $(AM_MAKEFLAGS) preinstall
touch preinstall-stamp
-CLEANFILES = preinstall-stamp
+CLEANFILES += preinstall-stamp
include_HEADERS =
+include_rtemsdir = $(includedir)/rtems
+include_rtems_HEADERS =
+
+include_rtems_rtemsdir = $(includedir)/rtems/rtems
+include_rtems_rtems_HEADERS =
+
if DEPRECATED
include_HEADERS += backward/asm.h backward/chain.h backward/clockdrv.h \
backward/confdefs.h backward/console.h backward/imfs.h backward/iosupp.h \
@@ -66,8 +74,7 @@ include_sys_HEADERS += libcsupport/include/sys/ioccom.h \
libcsupport/include/sys/cdefs.h
endif
-include_rtemsdir = $(includedir)/rtems
-include_rtems_HEADERS = include/rtems/bspIo.h include/rtems/userenv.h \
+include_rtems_HEADERS += include/rtems/bspIo.h include/rtems/userenv.h \
include/rtems/fs.h include/rtems/pci.h include/rtems/stdint.h \
include/rtems/concat.h include/rtems/tar.h
@@ -134,308 +141,9 @@ include_rtems_HEADERS += libmisc/untar/untar.h
## fsmount
include_rtems_HEADERS += libmisc/fsmount/fsmount.h
-PREINSTALL_DIRS =
-PREINSTALL_FILES =
-
-$(PROJECT_INCLUDE)/$(dirstamp):
- @$(mkdir_p) $(PROJECT_INCLUDE)
- @: > $(PROJECT_INCLUDE)/$(dirstamp)
-PREINSTALL_DIRS += $(PROJECT_INCLUDE)/$(dirstamp)
-
-if DEPRECATED
-$(PROJECT_INCLUDE)/asm.h: backward/asm.h $(PROJECT_INCLUDE)/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/asm.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/asm.h
-
-$(PROJECT_INCLUDE)/chain.h: backward/chain.h $(PROJECT_INCLUDE)/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/chain.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/chain.h
-
-$(PROJECT_INCLUDE)/clockdrv.h: backward/clockdrv.h $(PROJECT_INCLUDE)/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/clockdrv.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/clockdrv.h
-
-$(PROJECT_INCLUDE)/confdefs.h: backward/confdefs.h $(PROJECT_INCLUDE)/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/confdefs.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/confdefs.h
-
-$(PROJECT_INCLUDE)/console.h: backward/console.h $(PROJECT_INCLUDE)/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/console.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/console.h
-
-$(PROJECT_INCLUDE)/imfs.h: backward/imfs.h $(PROJECT_INCLUDE)/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/imfs.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/imfs.h
-
-$(PROJECT_INCLUDE)/iosupp.h: backward/iosupp.h $(PROJECT_INCLUDE)/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/iosupp.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/iosupp.h
-
-$(PROJECT_INCLUDE)/ringbuf.h: backward/ringbuf.h $(PROJECT_INCLUDE)/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/ringbuf.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/ringbuf.h
-
-$(PROJECT_INCLUDE)/rtc.h: backward/rtc.h $(PROJECT_INCLUDE)/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtc.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtc.h
-
-$(PROJECT_INCLUDE)/spurious.h: backward/spurious.h $(PROJECT_INCLUDE)/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/spurious.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/spurious.h
-
-$(PROJECT_INCLUDE)/timerdrv.h: backward/timerdrv.h $(PROJECT_INCLUDE)/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/timerdrv.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/timerdrv.h
-
-$(PROJECT_INCLUDE)/vmeintr.h: backward/vmeintr.h $(PROJECT_INCLUDE)/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/vmeintr.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/vmeintr.h
-
-if HAS_NETWORKING
-$(PROJECT_INCLUDE)/ftpd.h: backward/ftpd.h $(PROJECT_INCLUDE)/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/ftpd.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/ftpd.h
-endif
-
-$(PROJECT_INCLUDE)/motorola/$(dirstamp):
- @$(mkdir_p) $(PROJECT_INCLUDE)/motorola
- @: > $(PROJECT_INCLUDE)/motorola/$(dirstamp)
-PREINSTALL_DIRS += $(PROJECT_INCLUDE)/motorola/$(dirstamp)
-
-$(PROJECT_INCLUDE)/motorola/mc68681.h: backward/motorola/mc68681.h $(PROJECT_INCLUDE)/motorola/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/motorola/mc68681.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/motorola/mc68681.h
-
-$(PROJECT_INCLUDE)/motorola/mc68230.h: backward/motorola/mc68230.h $(PROJECT_INCLUDE)/motorola/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/motorola/mc68230.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/motorola/mc68230.h
-
-$(PROJECT_INCLUDE)/zilog/$(dirstamp):
- @$(mkdir_p) $(PROJECT_INCLUDE)/zilog
- @: > $(PROJECT_INCLUDE)/zilog/$(dirstamp)
-PREINSTALL_DIRS += $(PROJECT_INCLUDE)/zilog/$(dirstamp)
-
-$(PROJECT_INCLUDE)/zilog/z8536.h: backward/zilog/z8536.h $(PROJECT_INCLUDE)/zilog/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/zilog/z8536.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/zilog/z8536.h
-
-$(PROJECT_INCLUDE)/zilog/z8036.h: backward/zilog/z8036.h $(PROJECT_INCLUDE)/zilog/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/zilog/z8036.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/zilog/z8036.h
-
-$(PROJECT_INCLUDE)/zilog/z8030.h: backward/zilog/z8030.h $(PROJECT_INCLUDE)/zilog/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/zilog/z8030.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/zilog/z8030.h
-
-if !UNIX
-$(PROJECT_INCLUDE)/dosfs.h: backward/dosfs.h $(PROJECT_INCLUDE)/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/dosfs.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/dosfs.h
-endif
-
-if HAS_ITRON
-$(PROJECT_INCLUDE)/itron.h: backward/itron.h $(PROJECT_INCLUDE)/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/itron.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/itron.h
-endif
-endif
-
-if NEWLIB
-$(PROJECT_INCLUDE)/sys/$(dirstamp):
- @$(mkdir_p) $(PROJECT_INCLUDE)/sys
- @: > $(PROJECT_INCLUDE)/sys/$(dirstamp)
-PREINSTALL_DIRS += $(PROJECT_INCLUDE)/sys/$(dirstamp)
-
-$(PROJECT_INCLUDE)/stdint.h: libcsupport/include/stdint.h $(PROJECT_INCLUDE)/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/stdint.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/stdint.h
-
-$(PROJECT_INCLUDE)/inttypes.h: libcsupport/include/inttypes.h $(PROJECT_INCLUDE)/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/inttypes.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/inttypes.h
-
-$(PROJECT_INCLUDE)/tar.h: libcsupport/include/tar.h $(PROJECT_INCLUDE)/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/tar.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/tar.h
-
-$(PROJECT_INCLUDE)/sys/ioccom.h: libcsupport/include/sys/ioccom.h $(PROJECT_INCLUDE)/sys/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/sys/ioccom.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/sys/ioccom.h
-
-$(PROJECT_INCLUDE)/sys/filio.h: libcsupport/include/sys/filio.h $(PROJECT_INCLUDE)/sys/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/sys/filio.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/sys/filio.h
-
-$(PROJECT_INCLUDE)/sys/ioctl.h: libcsupport/include/sys/ioctl.h $(PROJECT_INCLUDE)/sys/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/sys/ioctl.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/sys/ioctl.h
-
-$(PROJECT_INCLUDE)/sys/sockio.h: libcsupport/include/sys/sockio.h $(PROJECT_INCLUDE)/sys/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/sys/sockio.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/sys/sockio.h
-
-$(PROJECT_INCLUDE)/sys/ttycom.h: libcsupport/include/sys/ttycom.h $(PROJECT_INCLUDE)/sys/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/sys/ttycom.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/sys/ttycom.h
-
-$(PROJECT_INCLUDE)/sys/termios.h: libcsupport/include/sys/termios.h $(PROJECT_INCLUDE)/sys/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/sys/termios.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/sys/termios.h
-
-$(PROJECT_INCLUDE)/sys/utsname.h: libcsupport/include/sys/utsname.h $(PROJECT_INCLUDE)/sys/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/sys/utsname.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/sys/utsname.h
-
-$(PROJECT_INCLUDE)/sys/cdefs.h: libcsupport/include/sys/cdefs.h $(PROJECT_INCLUDE)/sys/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/sys/cdefs.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/sys/cdefs.h
-endif
-
-$(PROJECT_INCLUDE)/rtems/$(dirstamp):
- @$(mkdir_p) $(PROJECT_INCLUDE)/rtems
- @: > $(PROJECT_INCLUDE)/rtems/$(dirstamp)
-PREINSTALL_DIRS += $(PROJECT_INCLUDE)/rtems/$(dirstamp)
-
-$(PROJECT_INCLUDE)/rtems/bspIo.h: include/rtems/bspIo.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/bspIo.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/bspIo.h
-
-$(PROJECT_INCLUDE)/rtems/userenv.h: include/rtems/userenv.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/userenv.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/userenv.h
-
-$(PROJECT_INCLUDE)/rtems/fs.h: include/rtems/fs.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/fs.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/fs.h
-
-$(PROJECT_INCLUDE)/rtems/pci.h: include/rtems/pci.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/pci.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/pci.h
-
-$(PROJECT_INCLUDE)/rtems/stdint.h: include/rtems/stdint.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/stdint.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/stdint.h
-
-$(PROJECT_INCLUDE)/rtems/concat.h: include/rtems/concat.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/concat.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/concat.h
-
-$(PROJECT_INCLUDE)/rtems/tar.h: include/rtems/tar.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/tar.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/tar.h
-
-$(PROJECT_INCLUDE)/rtems/imfs.h: libfs/src/imfs/imfs.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/imfs.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/imfs.h
-
-if !UNIX
-$(PROJECT_INCLUDE)/rtems/dosfs.h: libfs/src/dosfs/dosfs.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/dosfs.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/dosfs.h
-endif
-
-if !UNIX
-$(PROJECT_INCLUDE)/rtems/bdbuf.h: libblock/include/rtems/bdbuf.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/bdbuf.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/bdbuf.h
-
-$(PROJECT_INCLUDE)/rtems/blkdev.h: libblock/include/rtems/blkdev.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/blkdev.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/blkdev.h
-
-$(PROJECT_INCLUDE)/rtems/diskdevs.h: libblock/include/rtems/diskdevs.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/diskdevs.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/diskdevs.h
-
-$(PROJECT_INCLUDE)/rtems/ramdisk.h: libblock/include/rtems/ramdisk.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/ramdisk.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/ramdisk.h
-
-$(PROJECT_INCLUDE)/rtems/ide_part_table.h: libblock/include/rtems/ide_part_table.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/ide_part_table.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/ide_part_table.h
-endif
-
-if HAS_NETWORKING
-$(PROJECT_INCLUDE)/rtems/ftpd.h: ftpd/ftpd.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/ftpd.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/ftpd.h
-endif
-
-$(PROJECT_INCLUDE)/rtems/capture.h: libmisc/capture/capture.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/capture.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/capture.h
-
-$(PROJECT_INCLUDE)/rtems/capture-cli.h: libmisc/capture/capture-cli.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/capture-cli.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/capture-cli.h
-
-$(PROJECT_INCLUDE)/rtems/cpuuse.h: libmisc/cpuuse/cpuuse.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/cpuuse.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/cpuuse.h
-
-$(PROJECT_INCLUDE)/rtems/devnull.h: libmisc/devnull/devnull.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/devnull.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/devnull.h
-
-$(PROJECT_INCLUDE)/rtems/dumpbuf.h: libmisc/dumpbuf/dumpbuf.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/dumpbuf.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/dumpbuf.h
-
-$(PROJECT_INCLUDE)/rtems/monitor.h: libmisc/monitor/monitor.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/monitor.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/monitor.h
-
-$(PROJECT_INCLUDE)/rtems/mw_fb.h: libmisc/mw-fb/mw_fb.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/mw_fb.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/mw_fb.h
-
-$(PROJECT_INCLUDE)/rtems/mw_uid.h: libmisc/mw-fb/mw_uid.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/mw_uid.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/mw_uid.h
-
-if LIBSHELL
-$(PROJECT_INCLUDE)/rtems/shell.h: libmisc/shell/shell.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/shell.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/shell.h
-endif
-
-$(PROJECT_INCLUDE)/rtems/rtmonuse.h: libmisc/rtmonuse/rtmonuse.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/rtmonuse.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/rtmonuse.h
-
-if LIBSERDBG
-$(PROJECT_INCLUDE)/rtems/serdbgcnf.h: libmisc/serdbg/serdbgcnf.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/serdbgcnf.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/serdbgcnf.h
-
-$(PROJECT_INCLUDE)/rtems/serdbg.h: libmisc/serdbg/serdbg.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/serdbg.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/serdbg.h
-
-$(PROJECT_INCLUDE)/rtems/termios_printk_cnf.h: libmisc/serdbg/termios_printk_cnf.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/termios_printk_cnf.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/termios_printk_cnf.h
-
-$(PROJECT_INCLUDE)/rtems/termios_printk.h: libmisc/serdbg/termios_printk.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/termios_printk.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/termios_printk.h
-endif
-
-$(PROJECT_INCLUDE)/rtems/stackchk.h: libmisc/stackchk/stackchk.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/stackchk.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/stackchk.h
-
-$(PROJECT_INCLUDE)/rtems/untar.h: libmisc/untar/untar.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/untar.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/untar.h
-
-$(PROJECT_INCLUDE)/rtems/fsmount.h: libmisc/fsmount/fsmount.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
- $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/fsmount.h
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/fsmount.h
+all-local: $(PREINSTALL_FILES)
-CLEANFILES += $(PREINSTALL_FILES)
-DISTCLEANFILES = $(PREINSTALL_DIRS)
+include $(srcdir)/preinstall.am
include $(top_srcdir)/automake/subdirs.am
include $(top_srcdir)/automake/local.am