summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-11-30 10:37:29 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-11-30 10:37:29 +0000
commit60414096bb923ca2de4e63f9027d6837ee261f83 (patch)
tree569dc5e2ebdf444053ab5b329151118202477fcf /cpukit/Makefile.am
parent2003-11-30 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-60414096bb923ca2de4e63f9027d6837ee261f83.tar.bz2
2003-11-30 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Add $(dirstamp) to preinstallation rules.
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am21
1 files changed, 11 insertions, 10 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index 1137705609..7d776db7dd 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -31,24 +31,25 @@ EXTRA_DIST = $(AUTOMAKE_FILES)
PREINSTALL_FILES =
-$(PROJECT_INCLUDE)/rtems:
+$(PROJECT_INCLUDE)/rtems/$(dirstamp):
@$(mkinstalldirs) $(PROJECT_INCLUDE)/rtems
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems
+ @: > $(PROJECT_INCLUDE)/rtems/$(dirstamp)
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/$(dirstamp)
-$(PROJECT_INCLUDE)/rtems/bspIo.h: include/rtems/bspIo.h
- $(INSTALL_DATA) $< $@
+$(PROJECT_INCLUDE)/rtems/bspIo.h: include/rtems/bspIo.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/bspIo.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/bspIo.h
-$(PROJECT_INCLUDE)/rtems/userenv.h: include/rtems/userenv.h
- $(INSTALL_DATA) $< $@
+$(PROJECT_INCLUDE)/rtems/userenv.h: include/rtems/userenv.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/userenv.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/userenv.h
-$(PROJECT_INCLUDE)/rtems/fs.h: include/rtems/fs.h
- $(INSTALL_DATA) $< $@
+$(PROJECT_INCLUDE)/rtems/fs.h: include/rtems/fs.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/fs.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/fs.h
-$(PROJECT_INCLUDE)/rtems/stdint.h: include/rtems/stdint.h
- $(INSTALL_DATA) $< $@
+$(PROJECT_INCLUDE)/rtems/stdint.h: include/rtems/stdint.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/stdint.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/stdint.h
include $(top_srcdir)/automake/subdirs.am