summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2021-09-03 09:46:36 +0200
committerSebastian Huber <sebastian.huber@embedded-brains.de>2021-09-06 12:22:44 +0200
commit54b4b1f85af465acb4627ec423599a6c3b4a6fad (patch)
treef3bad4aa3f81fc8edee24fdb5c1138f39f128297 /cpukit/Makefile.am
parentscore: Remove TOD_TICKS_PER_SECOND_method() (diff)
downloadrtems-54b4b1f85af465acb4627ec423599a6c3b4a6fad.tar.bz2
score: Add _TOD_Is_valid_new_time_of_day()
Move the TOD validation to the callers of _TOD_Set(). This avoids dead code in case only rtems_clock_set() is used in an application because rtems_clock_set() always calls _TOD_Set() with a valid time of day.
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index 6b2c1fb5b7..591065adf3 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -1006,6 +1006,7 @@ librtemscpu_a_SOURCES += score/src/timespecgetasnanoseconds.c
librtemscpu_a_SOURCES += score/src/coretod.c
librtemscpu_a_SOURCES += score/src/coretodset.c
librtemscpu_a_SOURCES += score/src/coretodadjust.c
+librtemscpu_a_SOURCES += score/src/coretodcheck.c
librtemscpu_a_SOURCES += score/src/watchdoginsert.c
librtemscpu_a_SOURCES += score/src/coretodhookdata.c
librtemscpu_a_SOURCES += score/src/coretodhookregister.c