summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-19 07:29:05 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-19 07:29:05 +0000
commit3d1de205f620197d40ad019eb2d9e2dd5f0525c2 (patch)
treee4feaad3efa5aede8330a49535ef909658e24c77 /cpukit/Makefile.am
parent2004-01-18 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-3d1de205f620197d40ad019eb2d9e2dd5f0525c2.tar.bz2
2004-01-19 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* Makefile.am: Add PREINSTALL_DIRS.
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index 833e4bba14..9d8527ddfb 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -23,12 +23,13 @@ include_rtemsdir = $(includedir)/rtems
include_rtems_HEADERS = include/rtems/bspIo.h include/rtems/userenv.h \
include/rtems/fs.h include/rtems/stdint.h
+PREINSTALL_DIRS =
PREINSTALL_FILES =
$(PROJECT_INCLUDE)/rtems/$(dirstamp):
@$(mkdir_p) $(PROJECT_INCLUDE)/rtems
@: > $(PROJECT_INCLUDE)/rtems/$(dirstamp)
-PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/$(dirstamp)
+PREINSTALL_DIRS += $(PROJECT_INCLUDE)/rtems/$(dirstamp)
$(PROJECT_INCLUDE)/rtems/bspIo.h: include/rtems/bspIo.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/bspIo.h
@@ -47,6 +48,7 @@ $(PROJECT_INCLUDE)/rtems/stdint.h: include/rtems/stdint.h $(PROJECT_INCLUDE)/rte
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/stdint.h
CLEANFILES += $(PREINSTALL_FILES)
+DISTCLEANFILES = $(PREINSTALL_DIRS)
include $(top_srcdir)/automake/subdirs.am
include $(top_srcdir)/automake/local.am