summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorRyan Long <ryan.long@oarcorp.com>2021-04-28 12:40:56 -0400
committerJoel Sherrill <joel@rtems.org>2021-05-28 14:27:39 -0500
commit335f7050822262f029e7945b31b0f2bb2d889bcc (patch)
tree2229a86dbdc3d7e9ebf2274642dc62e238b32fea /cpukit/Makefile.am
parentmain_help.c: Do not care what char is returned by getchar() (diff)
downloadrtems-335f7050822262f029e7945b31b0f2bb2d889bcc.tar.bz2
libcsupport: Added futimens() and utimensat()
Created futimens.c and utimensat.c to add support for the POSIX methods futimens() and utimensat(). utime() and utimes() are considered obsolote by POSIX, but RTEMS will continue to support them. Closes #4396
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index db025ac6f8..7b99b78cc1 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -262,6 +262,8 @@ librtemscpu_a_SOURCES += libcsupport/src/unmount.c
librtemscpu_a_SOURCES += libcsupport/src/__usrenv.c
librtemscpu_a_SOURCES += libcsupport/src/utime.c
librtemscpu_a_SOURCES += libcsupport/src/utimes.c
+librtemscpu_a_SOURCES += libcsupport/src/futimens.c
+librtemscpu_a_SOURCES += libcsupport/src/utimensat.c
librtemscpu_a_SOURCES += libcsupport/src/utsname.c
librtemscpu_a_SOURCES += libcsupport/src/vprintk.c
librtemscpu_a_SOURCES += libcsupport/src/write.c