summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-03-29 12:43:20 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-03-29 12:43:20 +0000
commit2f4c86f83ee2c0c7cad9e1a14dd373a8bfb192fb (patch)
tree7a04f191f6d6ea54e30bd850957a6dd1f3b79b36 /cpukit/Makefile.am
parent2004-03-29 Ralf Corsepius <ralf_corsepius@rtems.org> (diff)
downloadrtems-2f4c86f83ee2c0c7cad9e1a14dd373a8bfb192fb.tar.bz2
2004-03-29 Ralf Corsepius <ralf_corsepius@rtems.org>
PR 561/rtems * include/rtems/concat.h: New. * Makefile.am: Add include/rtems/concat.h. PR/589 rtems * Makefile.am: Add include/rtems/pci.h. * Makefile.am: Include automake/compile.am. * configure.ac: RTEMS_TOP([..],[]).
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index 9d8527ddfb..53b276b2df 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -4,6 +4,7 @@
ACLOCAL_AMFLAGS = -I aclocal
+include $(top_srcdir)/automake/compile.am
include $(top_srcdir)/automake/multilib.am
SUBDIRS = . ada score rtems sapi posix itron
@@ -21,7 +22,8 @@ CLEANFILES = preinstall-stamp
include_rtemsdir = $(includedir)/rtems
include_rtems_HEADERS = include/rtems/bspIo.h include/rtems/userenv.h \
- include/rtems/fs.h include/rtems/stdint.h
+ include/rtems/fs.h include/rtems/pci.h include/rtems/stdint.h \
+ include/rtems/concat.h
PREINSTALL_DIRS =
PREINSTALL_FILES =
@@ -43,10 +45,18 @@ $(PROJECT_INCLUDE)/rtems/fs.h: include/rtems/fs.h $(PROJECT_INCLUDE)/rtems/$(dir
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/fs.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/fs.h
+$(PROJECT_INCLUDE)/rtems/pci.h: include/rtems/pci.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/pci.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/pci.h
+
$(PROJECT_INCLUDE)/rtems/stdint.h: include/rtems/stdint.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/stdint.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/stdint.h
+$(PROJECT_INCLUDE)/rtems/concat.h: include/rtems/concat.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/concat.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/concat.h
+
CLEANFILES += $(PREINSTALL_FILES)
DISTCLEANFILES = $(PREINSTALL_DIRS)