summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2018-12-19 09:25:29 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2018-12-21 07:56:35 +0100
commit2158621366c19dc32418ace48f49f4474a40c669 (patch)
tree424b6457086884a6ed0cdbef8366c23992e03cbc /cpukit/Makefile.am
parenttftpfs: Some bug fixes (diff)
downloadrtems-2158621366c19dc32418ace48f49f4474a40c669.tar.bz2
Add aligned_alloc() and memalign()
Ensure that the C++17 aligned new operator works. Close #3666.
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index 143c5d6686..23f4f40521 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -78,6 +78,7 @@ librtemscpu_a_SOURCES += libcrypt/crypt-sha512.c
librtemscpu_a_SOURCES += libcrypt/misc.c
librtemscpu_a_SOURCES += libcsupport/src/access.c
librtemscpu_a_SOURCES += libcsupport/src/arc4random_getentropy_fail.c
+librtemscpu_a_SOURCES += libcsupport/src/alignedalloc.c
librtemscpu_a_SOURCES += libcsupport/src/__assert.c
librtemscpu_a_SOURCES += libcsupport/src/assoc32tostring.c
librtemscpu_a_SOURCES += libcsupport/src/assoclocalbyname.c