summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorSebastian Huber <sebastian.huber@embedded-brains.de>2019-12-16 14:32:47 +0100
committerSebastian Huber <sebastian.huber@embedded-brains.de>2020-02-12 09:08:36 +0100
commit00c7ad4cab30aba80639ace29526c1efc2779074 (patch)
tree2ab8b6c899aa15c4b0b0d34e2de16314d6dcb8d0 /cpukit/Makefile.am
parentscore: Simplify TLS area allocation (diff)
downloadrtems-00c7ad4cab30aba80639ace29526c1efc2779074.tar.bz2
score: Split stack allocator configuration
This allows the linker garbage collection to perform its work. Update #3835.
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index 303c0afe9a..06e98c31ff 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -922,6 +922,7 @@ librtemscpu_a_SOURCES += score/src/schedulercbsgetserverid.c
librtemscpu_a_SOURCES += score/src/schedulercbssetparameters.c
librtemscpu_a_SOURCES += score/src/schedulercbsreleasejob.c
librtemscpu_a_SOURCES += score/src/schedulercbsunblock.c
+librtemscpu_a_SOURCES += score/src/stackallocator.c
librtemscpu_a_SOURCES += score/src/pheapallocate.c
librtemscpu_a_SOURCES += score/src/pheapextend.c
librtemscpu_a_SOURCES += score/src/pheapfree.c