summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel@rtems.org>2021-10-01 14:56:34 -0500
committerJoel Sherrill <joel@rtems.org>2021-10-07 10:31:38 -0500
commitc8a10609883c67629ea029be617a42b75d168f0f (patch)
tree77fb5ef6d9a04763840be4a205516d5fb542d6e4 /cpukit/Makefile.am
parentpowerpc/motorola_powerpc: Map LibBSD bus space to the PCI base address (diff)
downloadrtems-c8a10609883c67629ea029be617a42b75d168f0f.tar.bz2
Add support for IDLE Thread stack allocator
Add a stack allocator hook specifically for allocation of IDLE thread stacks. This allows the user to decide if IDLE thread stacks are statically allocated or handled by the same custom allocator mechanism as other thread stacks. Closes #4520.
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index 18eda95543..202cf3c346 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -930,6 +930,7 @@ librtemscpu_a_SOURCES += score/src/schedulercbssetparameters.c
librtemscpu_a_SOURCES += score/src/schedulercbsreleasejob.c
librtemscpu_a_SOURCES += score/src/schedulercbsunblock.c
librtemscpu_a_SOURCES += score/src/stackallocator.c
+librtemscpu_a_SOURCES += score/src/stackallocatorforidle.c
librtemscpu_a_SOURCES += score/src/pheapallocate.c
librtemscpu_a_SOURCES += score/src/pheapextend.c
librtemscpu_a_SOURCES += score/src/pheapfree.c