summaryrefslogtreecommitdiffstats
path: root/cpukit/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2005-02-08 04:04:46 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2005-02-08 04:04:46 +0000
commitfa73ccb0b85e09122e7dcde429e49b8448e696d7 (patch)
treecddb4001bce59131b5b1b999b788559a5cdd7487 /cpukit/Makefile.am
parent2005-02-08 Ralf Corsepius <ralf.corsepius@rtems.org> (diff)
downloadrtems-fa73ccb0b85e09122e7dcde429e49b8448e696d7.tar.bz2
2005-02-08 Ralf Corsepius <ralf.corsepius@rtems.org>
* configure.ac: Add new header guard to cpuopts.h. * Makefile.am: Add libfs, libblock, ftpd header install rules. * libfs/Makefile.am, libblock/Makefile.am, ftpd/Makefile.am: Remove header install rules.
Diffstat (limited to 'cpukit/Makefile.am')
-rw-r--r--cpukit/Makefile.am58
1 files changed, 58 insertions, 0 deletions
diff --git a/cpukit/Makefile.am b/cpukit/Makefile.am
index e5c8afa90e..6f7b2e15b2 100644
--- a/cpukit/Makefile.am
+++ b/cpukit/Makefile.am
@@ -71,6 +71,26 @@ include_rtems_HEADERS = include/rtems/bspIo.h include/rtems/userenv.h \
include/rtems/fs.h include/rtems/pci.h include/rtems/stdint.h \
include/rtems/concat.h include/rtems/tar.h
+## libfs
+include_rtems_HEADERS += libfs/src/imfs/imfs.h
+
+if !UNIX
+include_rtems_HEADERS += libfs/src/dosfs/dosfs.h
+endif
+
+## libblock
+if !UNIX
+include_rtems_HEADERS += libblock/include/rtems/bdbuf.h \
+ libblock/include/rtems/blkdev.h libblock/include/rtems/diskdevs.h \
+ libblock/include/rtems/ramdisk.h \
+ libblock/include/rtems/ide_part_table.h
+endif
+
+## ftpd
+if HAS_NETWORKING
+include_rtems_HEADERS += ftpd/ftpd.h
+endif
+
## capture
include_rtems_HEADERS += libmisc/capture/capture.h \
libmisc/capture/capture-cli.h
@@ -304,6 +324,44 @@ $(PROJECT_INCLUDE)/rtems/tar.h: include/rtems/tar.h $(PROJECT_INCLUDE)/rtems/$(d
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/tar.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/tar.h
+$(PROJECT_INCLUDE)/rtems/imfs.h: libfs/src/imfs/imfs.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/imfs.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/imfs.h
+
+if !UNIX
+$(PROJECT_INCLUDE)/rtems/dosfs.h: libfs/src/dosfs/dosfs.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/dosfs.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/dosfs.h
+endif
+
+if !UNIX
+$(PROJECT_INCLUDE)/rtems/bdbuf.h: libblock/include/rtems/bdbuf.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/bdbuf.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/bdbuf.h
+
+$(PROJECT_INCLUDE)/rtems/blkdev.h: libblock/include/rtems/blkdev.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/blkdev.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/blkdev.h
+
+$(PROJECT_INCLUDE)/rtems/diskdevs.h: libblock/include/rtems/diskdevs.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/diskdevs.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/diskdevs.h
+
+$(PROJECT_INCLUDE)/rtems/ramdisk.h: libblock/include/rtems/ramdisk.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/ramdisk.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/ramdisk.h
+
+$(PROJECT_INCLUDE)/rtems/ide_part_table.h: libblock/include/rtems/ide_part_table.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/ide_part_table.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/ide_part_table.h
+endif
+
+if HAS_NETWORKING
+$(PROJECT_INCLUDE)/rtems/ftpd.h: ftpd/ftpd.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
+ $(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/ftpd.h
+PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/ftpd.h
+endif
+
$(PROJECT_INCLUDE)/rtems/capture.h: libmisc/capture/capture.h $(PROJECT_INCLUDE)/rtems/$(dirstamp)
$(INSTALL_DATA) $< $(PROJECT_INCLUDE)/rtems/capture.h
PREINSTALL_FILES += $(PROJECT_INCLUDE)/rtems/capture.h