summaryrefslogtreecommitdiffstats
path: root/contrib/crossrpms/solaris2.7/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2006-02-15 15:04:03 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2006-02-15 15:04:03 +0000
commitc0b13f02d8ce3f4c381d7bbcba91d94d01e92a15 (patch)
tree39fcbe26e8c2453e8e977630ecf8c82c04e72ba0 /contrib/crossrpms/solaris2.7/Makefile.am
parentNew. Use FSF sources. (diff)
downloadrtems-c0b13f02d8ce3f4c381d7bbcba91d94d01e92a15.tar.bz2
New.
Diffstat (limited to '')
-rw-r--r--contrib/crossrpms/solaris2.7/Makefile.am69
1 files changed, 67 insertions, 2 deletions
diff --git a/contrib/crossrpms/solaris2.7/Makefile.am b/contrib/crossrpms/solaris2.7/Makefile.am
index 297790bf9e..49ed2cd0bb 100644
--- a/contrib/crossrpms/solaris2.7/Makefile.am
+++ b/contrib/crossrpms/solaris2.7/Makefile.am
@@ -2,6 +2,25 @@
TARGET = sparc-sun-solaris2.7
+noinst_DATA =
+CLEANFILES =
+
+SOLARIS_VERS = 2.7
+SOLARIS_RPMREL = 0.20060213.0
+
+$(TARGET)-libs.spec: libs.spec.in
+ sed -e "/[@]INSTALL_POST[@]/r ../common/installpost.add" \
+ -e "/[@]INSTALL_POST[@]/d" \
+ -e "/[@]FIND_REQPROV[@]/r ../common/find-reqprov.add" \
+ -e "/[@]FIND_REQPROV[@]/d" \
+ -e "s/[@]tool_target[@]/$(TARGET)/g" \
+ -e "s/[@]SOLARIS_VERS[@]/$(SOLARIS_VERS)/g" \
+ -e "s/[@]SOLARIS_RPMREL[@]/$(SOLARIS_RPMREL)/g" \
+ $(srcdir)/libs.spec.in > $@
+CLEANFILES += $(TARGET)-libs.spec
+noinst_DATA += $(TARGET)-libs.spec
+
+
BINUTILS_VERS = 2.16.1
BINUTILS_RPMREL = 0.20060214.0
@@ -12,8 +31,8 @@ BINUTILS_SUBPACKAGES += $(top_builddir)/common/clean.add
BINUTILS_SUBPACKAGES += ../binutils/target-binutils.add
BINUTILS_SUBPACKAGES += ../binutils/base-binutils.add
-$(TARGET)-binutils.spec.in: $(BINUTILS_SUBPACKAGES)
- cat $^ | sed \
+$(TARGET)-binutils.spec.in: $(BINUTILS_SUBPACKAGES) binutils-sources.add
+ cat $(BINUTILS_SUBPACKAGES) | sed \
-e "/[@]SOURCES[@]/r ./binutils-sources.add" \
-e "/[@]SOURCES[@]/d" \
-e '/^%define _prefix.*$$/d' \
@@ -35,3 +54,49 @@ $(TARGET)-binutils.spec: $(TARGET)-binutils.spec.in
$(srcdir)/$(TARGET)-binutils.spec.in > $@
CLEANFILES += $(TARGET)-binutils.spec
noinst_DATA += $(TARGET)-binutils.spec
+
+
+GCC_VERS = 4.0.2
+GCC_RPMREL = 0.20060213.0
+
+GCC_SUBPACKAGES = $(top_builddir)/common/common.add
+GCC_SUBPACKAGES += ../gccnewlib/gccnewlib.add
+GCC_SUBPACKAGES += ../gccnewlib/install.add
+GCC_SUBPACKAGES += ../gccnewlib/rpm-install.add
+GCC_SUBPACKAGES += $(top_builddir)/common/clean.add
+GCC_SUBPACKAGES += ../gccnewlib/target-gcc.add
+GCC_SUBPACKAGES += ../gccnewlib/base-gcc.add
+GCC_SUBPACKAGES += ../gccnewlib/target-c++.add
+
+$(TARGET)-gcc.spec.in: $(GCC_SUBPACKAGES) gcc-sources.add
+ cat $(GCC_SUBPACKAGES) | sed \
+ -e "/[@]SOURCES[@]/r ./gcc-sources.add" \
+ -e "/[@]SOURCES[@]/d" \
+ -e '/^%define _prefix.*$$/d' \
+ -e '/^%define rpmgroup.*$$/d' \
+ -e '/^%define gcc_target.*$$/d' \
+ -e "s,[@]rpmprefix[@],,g" \
+ -e "s,rtems[@]osversion[@],rtems,g" \
+ -e "s,%{rpmgroup},Development/Tools,g" \
+ -e "s,[@]tool_target[@]-libc,@tool_target@-sys-root,g" \
+ -e "s,= %{newlib_version}-%{release},," \
+ -e "/--with-newlib/d" \
+ -e "/^%package -n @tool_target@-gcc/d" \
+ -e 's,^%define build_newlib.*$$,%define build_newlib 0,' \
+ > $(TARGET)-gcc.spec.in
+CLEANFILES += $(TARGET)-gcc.spec.in
+
+$(TARGET)-gcc.spec: $(TARGET)-gcc.spec.in
+ sed \
+ -e "s/[@]tool_target[@]/$(TARGET)/g" \
+ -e "s/[@]GCC_VERS[@]/$(GCC_VERS)/g" \
+ -e "s/[@]GCC_RPMREL[@]/$(GCC_RPMREL)/g" \
+ -e "/@PATCH0@/d" \
+ -e "/@PATCH1@/d" \
+ -e "/@PATCH2@/d" \
+ -e "/@PATCH3@/d" \
+ -e "/@PATCH4@/d" \
+ -e "/@PATCH5@/d" \
+ $(srcdir)/$(TARGET)-gcc.spec.in > $@
+CLEANFILES += $(TARGET)-gcc.spec
+noinst_DATA += $(TARGET)-gcc.spec