summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-03-23 18:02:17 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-03-23 18:02:17 +0000
commit9b8baa128b4e7d0696f9ad995927cf2e5162649f (patch)
tree0dc430b7dd5a70d7025e20227696d5d7cfd95441 /configure.in
parentRegenerated. (diff)
downloadrtems-9b8baa128b4e7d0696f9ad995927cf2e5162649f.tar.bz2
Automake II patch from Ralf Corsepius <corsepiu@faw.uni-ulm.de>. Email
description follows: Description: * automake for *all* tool subdirectories (Makefile.am, configure.in etc.) * autogen now also considers CONFIG_HEADER (generates stamp-h.ins and config.h.ins) * c/src/tests/tools/generic/difftest and c/src/tests/tools/generic/sorttimes generated by configure scripts * c/update-tools/ampolish, beautifier for Makefile.ams, similar to acpolish * rtems-polish.sh added to c/update-tools/ + ampolish support * New subdirectory ./automake, contains automake -Makefile fragments to support RTEMS make "debug, debug_install, profile, profile_install" for native Makefile.ams (== ignore these make targets). * aclocal/rtems-top.m4's RTEMS_TOP now reads the automake makefile variable VERSION from RTEMS ./VERSION file. * ./configure.in uses the macros from aclocal + support for the tools' configure scripts Remarks: * To run rtems-polish.sh, "cd <rtems-source-tree>; ./c/update-tools/rtems-polish.sh" * AFAIS, now all native subdirectories are converted to automake (Please drop me a note, if I forgot something). * Unless you notice something fatal, IMO the time has come for a public try (== snapshot). I do not intend to send more automake related patches within, say 2 weeks, to give these patches time to settle and to give me some time to think on how to continue. * The patch assumes installation to the new main installation directory [$(prefix)].
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in21
1 files changed, 18 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index ec66962e03..5b07e3794a 100644
--- a/configure.in
+++ b/configure.in
@@ -179,8 +179,14 @@ if test "$target_cpu" = "unix" ; then
fi
fi
+# Collect config subdirs for exec/score/tools
+t="c/src/exec/score/tools"
+scoretools_cfgdirs="$t/generic"
+if test -d $srcdir/$t/$target_cpu; then
+ scoretools_cfgdirs="$scoretools_cfgdirs $t/$target_cpu"
+fi
+
# find all the Executive Makefiles
-RTEMS_CHECK_MAKEFILE(c/src/exec/score/tools/$target_cpu)
RTEMS_CHECK_MAKEFILE(c/src/exec/rtems)
RTEMS_CHECK_MAKEFILE(c/src/exec/sapi)
RTEMS_CHECK_MAKEFILE(c/src/exec/score/cpu/$target_cpu)
@@ -260,6 +266,13 @@ if test -d "$srcdir/c/src/lib/libbsp/$target_cpu"; then
bspdirs="$bspdirs $bspdir"
RTEMS_CHECK_MAKEFILE(c/src/lib/libbsp/$bspcpudir$bspdir)
RTEMS_CHECK_MAKEFILE(c/src/lib/libbsp/${bspcpudir}shared)
+
+ # HACK: sed out bsp-tools from makefiles
+ t="c/src/lib/libbsp/$bspcpudir$bspdir/tools"
+ if test -d "$srcdir/$t"; then
+ bsptools_cfgdirs="$bsptools_cfgdirs $t"
+ makefiles=`echo "$makefiles" | sed -e "s%$t/Makefile%%g"`
+ fi
fi
else
AC_MSG_ERROR([unable to find libbsp directory ($bspdir) for $i])
@@ -320,6 +333,7 @@ if test "$tests_enabled" = "yes"; then
if test "$RTEMS_HAS_POSIX_API" = "yes"; then
RTEMS_CHECK_MAKEFILE(c/src/tests/psxtests)
fi
+ AC_CONFIG_SUBDIRS(c/src/tests/tools/generic)
fi
# If the HWAPI is enabled, the find the HWAPI Makefiles
@@ -370,6 +384,9 @@ RTEMS_CHECK_MAKEFILE(c/src/lib/libmisc)
RTEMS_CHECK_MAKEFILE(c/src/tests/samples)
AC_CONFIG_SUBDIRS(c/build-tools)
+AC_CONFIG_SUBDIRS($scoretools_cfgdirs)
+AC_CONFIG_SUBDIRS($bsptools_cfgdirs)
+
# FIXME: libwapi needs a separate configure.in in future ;-
# AC_CONFIG_SUBDIRS(c/src/lib/libwapi)
@@ -394,7 +411,6 @@ c/src/exec/score/${inline_dir}/rtems/Makefile
c/src/exec/score/${inline_dir}/rtems/score/Makefile
c/src/exec/score/src/Makefile
c/src/exec/score/tools/Makefile
-c/src/exec/score/tools/generic/Makefile
c/src/exec/wrapup/Makefile
c/src/exec/wrapup/rtems/Makefile
c/src/lib/Makefile
@@ -411,7 +427,6 @@ c/src/tests/support/include/Makefile
c/src/tests/support/stubdr/Makefile
c/src/tests/support/wrapup/Makefile
c/src/tests/tools/Makefile
-c/src/tests/tools/generic/Makefile
$makefiles
c/update-tools/Makefile)