summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1997-12-10 16:58:00 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1997-12-10 16:58:00 +0000
commit674c900f24a91e1503d5f6f07bbe2f423ef5bf4b (patch)
treeb64c1e64560022a18203d1c236d25b6d03945959 /configure.in
parentAdded missing dependency for libmisc.a based on a bug report by Phil Wilshire. (diff)
downloadrtems-674c900f24a91e1503d5f6f07bbe2f423ef5bf4b.tar.bz2
Modified a lot of files to take a first cut at supporting building from
any directory in the build tree. The only variable which must be set before the command "gmake" is invoked is RTEMS_BSP (e.g. RTEMS_BSP=erc32).
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 10 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 213eb4a555..4f0bb25067 100644
--- a/configure.in
+++ b/configure.in
@@ -143,7 +143,7 @@ case "${target}" in
target_cpu=no_cpu
RTEMS_HAS_POSIX_API=no
;;
- powerpc-rtems*|ppc-rtems*)
+ powerpc-*tems*)
target_cpu=ppc
;;
sparc-sun-solaris*) # unix "simulator" port
@@ -194,10 +194,16 @@ if test -d "$srcdir/c/src/lib/libbsp/$target_cpu"; then
Makefile*);;
READ*);;
CVS*);;
- go32*);; # so the i386 port can pick up the other Makefiles
+ pxfl*);;
+ go32*);; # so the i386 port can pick up the other Makefiles
+ # Now account for BSPs with build variants
+ gen68360) rtems_bsp="$rtems_bsp gen68360 gen68360_040";;
+ p4000) rtems_bsp="$rtems_bsp p4600 p4650";;
+ mvme162) rtems_bsp="$rtems_bsp mvme162 mvme162lx";;
*) rtems_bsp="$rtems_bsp $file";;
esac;
done
+
AC_MSG_RESULT([$rtems_bsp])
fi
@@ -207,7 +213,7 @@ if test -d "$srcdir/c/src/lib/libbsp/$target_cpu"; then
if test ! -r "$srcdir/c/make/custom/${i}.cfg"; then
AC_MSG_ERROR([no make/custom/${i}.cfg file for BSP $i])
fi
-
+
# account for "aliased" bsps which share source code
case $i in
mvme162lx) bspdir=mvme162 ;; # mvme162 board variant
@@ -378,6 +384,7 @@ c/src/tests/tools/Makefile
c/src/tests/tools/generic/Makefile
$makefiles
c/make/host.cfg
+c/make/target.cfg
c/make/Templates/Makefile.inc
c/update-tools/Makefile)