summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1998-07-23 19:39:25 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1998-07-23 19:39:25 +0000
commit613ab621df0db6d7110c7a9e657b19a0eac45667 (patch)
tree9d55a689bf0eba27adf4dcaff119ad778a5f1df5 /configure.in
parentRemoved consolex from build list. This file should be obsoleted by the (diff)
downloadrtems-613ab621df0db6d7110c7a9e657b19a0eac45667.tar.bz2
Patch from Dario Alcocer <alcocer@connectnet.com> and Ralf Corsepius
<corsepiu@faw.uni-ulm.de> which attempts to detect when the UNIX port is being configured on a system without System V IPC support. This is an optional component on both FreeBSD and Linux systems. Most Linux 2.x kernels ship with it enabled but it is still a real risk. This test may have undesirable side-effects on some hosts. We will address those conflicts as they arise.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 7b4aa1de2e..b4ccd67976 100644
--- a/configure.in
+++ b/configure.in
@@ -244,6 +244,22 @@ dnl check for host library functions
dnl NOTE: must be called after AC_PROG_CC
AC_CHECK_FUNCS(strerror)
+dnl check for SysV IPC used by simulators
+if test "$target_cpu" = "unix" ; then
+ RTEMS_SYSV_SEM
+ if test "$rtems_cv_sysv_sem" != "yes" ; then
+ AC_MSG_ERROR([System V semaphores don't work, required by simulator])
+ fi
+ RTEMS_SYSV_SHM
+ if test "$rtems_cv_sysv_shm" != "yes" ; then
+ AC_MSG_ERROR([System V shared memory doesn't work, required by simulator])
+ fi
+ RTEMS_SYSV_MSG
+ if test "$rtems_cv_sysv_msg" != "yes" ; then
+ AC_MSG_ERROR([System V messages don't work, required by simulator])
+ fi
+fi
+
# find all the Executive Makefiles
RTEMS_CHECK_MAKEFILE(c/src/exec/score/tools/$target_cpu)
RTEMS_CHECK_MAKEFILE(c/src/exec/rtems)