summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1998-05-18 16:36:09 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1998-05-18 16:36:09 +0000
commit0b767238bcb80849bf48ff47510ee9196f92000d (patch)
tree2d77ae526d9c72c0c794230bb8b518187298e7b9 /configure.in
parentRegenerated. (diff)
downloadrtems-0b767238bcb80849bf48ff47510ee9196f92000d.tar.bz2
Support bsp_specs style building for linux and solaris. Improved C++
support.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in20
1 files changed, 12 insertions, 8 deletions
diff --git a/configure.in b/configure.in
index a16c713ac7..993479e61d 100644
--- a/configure.in
+++ b/configure.in
@@ -134,8 +134,6 @@ case "${target}" in
RTEMS_HOST=Linux
# override these settings
RTEMS_HAS_POSIX_API=no
- RTEMS_USE_GCC272=yes
- RTEMS_LIBC_DIR=/usr
;;
no_cpu-*rtems*)
target_cpu=no_cpu
@@ -146,8 +144,6 @@ case "${target}" in
RTEMS_HOST=Solaris
# override these settings
RTEMS_HAS_POSIX_API=no
- RTEMS_USE_GCC272=yes
- RTEMS_LIBC_DIR=/usr
;;
*)
RTEMS_CANONICAL_TARGET_CPU
@@ -182,23 +178,30 @@ fi
dnl check target cc
CC="$program_prefix"gcc
RTEMS_PROG_CC
+dnl check if the compiler supports --specs
+RTEMS_GCC_SPECS
+dnl check if the target compiler may use --pipe
+RTEMS_GCC_PIPE
dnl check if the compiler supports --specs if gcc28 is requested
if test "$RTEMS_USE_GCC272" != "yes" ; then
- RTEMS_GCC_SPECS
if test "$rtems_cv_gcc_specs" = "no"; then
AC_MSG_WARN([*** disabling --enable-gcc28])
RTEMS_USE_GCC272=yes
fi
fi
-dnl check if the target compiler may use --pipe
-RTEMS_GCC_PIPE
-
dnl check for g++
if test "$RTEMS_HAS_CPLUSPLUS" = "yes"; then
CXX="$program_prefix"g++
RTEMS_PROG_CXX
+ if test "$rtems_cv_prog_cc_cross" != "$rtems_cv_prog_cxx_cross"; then
+ AC_MSG_ERROR([***]
+ [Inconsistency in compiler configuration:]
+ [Target C compiler and Target C++ compiler]
+ [must both ether be cross compilers or native compilers]
+ [Hint: LD_LIBRARY_PATH ?] )
+ fi
AC_PATH_PROG(CXX_FOR_TARGET,"$program_prefix"g++,no)
else
CXX_FOR_TARGET="no"
@@ -366,6 +369,7 @@ AC_ARG_ENABLE(hwapi, \
AC_MSG_RESULT(no)
)
+AC_SUBST(rtems_cv_prog_cc_cross)
AC_SUBST(RTEMS_BSP_LIST)
AC_SUBST(RTEMS_HOST)
AC_SUBST(RTEMS_LIBC_DIR)