summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Johns <chrisj@rtems.org>2018-04-09 16:18:09 +1000
committerChris Johns <chrisj@rtems.org>2018-04-10 08:22:07 +1000
commit9f6f0261c172bee5463bb6724809e8486c9197ea (patch)
tree6db934629ca44390fa656fbb303b528dc2f7732f /configure.ac
parentbsp/genmcf548x: Fix IRQ support (diff)
downloadrtems-9f6f0261c172bee5463bb6724809e8486c9197ea.tar.bz2
Generate an error if no valid gcc is found when configure runs.
Close #3385.
Diffstat (limited to '')
-rw-r--r--configure.ac6
1 files changed, 5 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2d1842e2d7..d1fb7f23da 100644
--- a/configure.ac
+++ b/configure.ac
@@ -25,12 +25,16 @@ RTEMS_ENABLE_MULTIPROCESSING
RTEMS_ENABLE_POSIX
RTEMS_ENABLE_NETWORKING
RTEMS_ENABLE_CXX
-RTEMS_ENABLE_TESTS
+RTEMS_ENABLE_TESTS
RTEMS_ENABLE_RTEMS_DEBUG
RTEMS_ENABLE_RTEMSBSP
RTEMS_ENABLE_PARAVIRT
RTEMS_ENABLE_DRVMGR
+## Check if there are valid tools install and in the path.
+RTEMS_CHECK_TOOL(RTEMS_CC,gcc)
+test -z "$RTEMS_CC" && AC_MSG_ERROR([no acceptable cc found in \$PATH])
+
## NOTES:
## * tools/build are host-native tools to be installed on the host.
## * tools/cpu are host-native or host-cross-target-tools