summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-03-25 08:50:16 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-03-25 08:50:16 +0000
commit0b22af60bb3fcea83e837c7b0fcfd2691d0ada56 (patch)
tree76ce73f4a35c788187454d8ce5c7556ff1f583a1 /configure.ac
parentMerger from rtems-4-6-branch. (diff)
downloadrtems-0b22af60bb3fcea83e837c7b0fcfd2691d0ada56.tar.bz2
Merger from rtems-4-6-branch.
Diffstat (limited to '')
-rw-r--r--configure.ac12
1 files changed, 5 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 79f3ebda81..d2b90cf68c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -49,17 +49,16 @@ AC_MSG_WARN([]
fi
## NOTES:
-## The tools/*-directories situation is unclear
## * tools/build are host-native tools to be installed on the host.
## * tools/cpu are host-native or host-cross-target-tools
-## * tools/update are build-host-native tools
-# these tools are built for the build environment
-#
-RTEMS_BUILD_CONFIG_SUBDIRS([tools/update])
+RTEMS_BUILD_CONFIG_SUBDIRS([tools/build])
+RTEMS_BUILD_CONFIG_SUBDIRS([tools/cpu])
+# Some BSPs carelessly apply these tools as build-tools
+AS_IF([test $host != $build],[
RTEMS_HOST_CONFIG_SUBDIRS([tools/build])
-RTEMS_HOST_CONFIG_SUBDIRS([tools/cpu])
+])
AS_IF([test x"${enable_docs}" = x"yes"],
[RTEMS_HOST_CONFIG_SUBDIRS([doc])])
@@ -70,7 +69,6 @@ AS_IF([test x"$enable_multilib" = x"yes"],[
RTEMS_TARGET_CONFIG_SUBDIRS([c])
AC_CONFIG_FILES([Makefile
-tools/Makefile
make/Makefile
make/custom/Makefile
])