summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2002-01-20 17:03:51 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2002-01-20 17:03:51 +0000
commit003d4da3fcd6f0530f643997e3c42c30d1ebd450 (patch)
tree4264e46b44c07291cd7ec87b61f85a59fbc57f05 /configure.ac
parentregenerated (diff)
downloadrtems-003d4da3fcd6f0530f643997e3c42c30d1ebd450.tar.bz2
2002-01-19 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.ac: Add --enable-docs support. Add RTEMS_HOST_CONFIG_SUBDIRS(doc). Remove doc/Makefile. * Makefile.am: Add HOST_SUBDIRS to SUBDIRS. Remove doc from hard-coded SUBDIRS. * README.configure: Added a bit of information on this new option.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 4dc63d6478..fe31dda1cb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -35,6 +35,10 @@ RTEMS_ENABLE_RTEMS_DEBUG
RTEMS_ENABLE_RTEMSBSP(dummy)
RTEMS_ENABLE_MULTILIB
+AC_ARG_ENABLE([docs],
+ [AC_HELP_STRING([--enable-docs],[enable building documentation
+ (default:disabled)])])
+
if test $host != $build; then
AC_MSG_WARN([]
[*** *** *** WARNING *** *** ***]
@@ -59,6 +63,9 @@ RTEMS_BUILD_CONFIG_SUBDIRS([tools/update])
RTEMS_HOST_CONFIG_SUBDIRS([tools/build])
RTEMS_HOST_CONFIG_SUBDIRS([tools/cpu])
+AS_IF([test x"${enable_docs}" = x"yes"],
+ [RTEMS_HOST_CONFIG_SUBDIRS([doc])])
+
RTEMS_TARGET_CONFIG_SUBDIRS([c/make])
if test x"$enable_multilib" = x"yes"; then
RTEMS_TARGET_CONFIG_SUBDIRS([c/src/exec])
@@ -73,6 +80,6 @@ make/Makefile
make/custom/Makefile
make/Templates/Makefile
make/compilers/Makefile
-doc/Makefile])
+])
AC_OUTPUT