summaryrefslogtreecommitdiffstats
path: root/c/update-tools/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-04-12 15:41:33 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-04-12 15:41:33 +0000
commit8cdb582b49c1528216cfd316183536735474c899 (patch)
tree88c7168b08ee935044266ff9a4c3b4b6d060d517 /c/update-tools/configure.in
parentAdded line to initialize timer_max. (diff)
downloadrtems-8cdb582b49c1528216cfd316183536735474c899.tar.bz2
Patch from Ralf Corsepius <corsepiu@faw.uni-ulm.de>:
This patch addresses a few minor issues and contains a few (minor) preparations for automake. * configure.in: Fix for handing c/src/tests subdirectory handling (FIX) * aclocal/rtems-top.m4: + Add TARGET_SUBDIR and --with-target-subdir (preparation of future enhancements for cross-compiling) + Activate RTEMS_ROOT handling (automake preparation) * automake/*.am: replace comments "#" with "##" so that comments won't get included into Makefile.in's anymore * c/update-tools/* automake support (NEW) * ./autogen update/enhancement (cf. ./autogen for details) After applying this patch please run: ./autogen cvs add c/update-tools/configure.in cvs add c/update-tools/Makefile.am cvs add c/update-tools/aclocal.m4
Diffstat (limited to '')
-rw-r--r--c/update-tools/configure.in22
1 files changed, 22 insertions, 0 deletions
diff --git a/c/update-tools/configure.in b/c/update-tools/configure.in
new file mode 100644
index 0000000000..b270d7fef2
--- /dev/null
+++ b/c/update-tools/configure.in
@@ -0,0 +1,22 @@
+#
+# $Id$
+#
+
+AC_PREREQ(2.13)
+AC_INIT(rtems-polish.sh)
+AC_CONFIG_AUX_DIR(../..)
+RTEMS_TOP(../..)
+
+AC_CANONICAL_HOST
+
+AM_INIT_AUTOMAKE(rtems-update-tools,$RTEMS_VERSION,no)
+
+RTEMS_PATH_KSH
+RTEMS_PATH_PERL
+
+AM_CONDITIONAL(PERL,test -n "$PERL")
+
+RTEMS_TOOLPATHS
+AC_OUTPUT(
+Makefile
+)