summaryrefslogtreecommitdiffstats
path: root/c/src/wrapup/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2001-12-20 17:32:49 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2001-12-20 17:32:49 +0000
commitf92cc34b38355c462fd394f098a561d403bc42e9 (patch)
treef2fe303c95b22a042b3dd9d07b3b9b624e08840a /c/src/wrapup/configure.ac
parent2001-12-20 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-f92cc34b38355c462fd394f098a561d403bc42e9.tar.bz2
2001-12-20 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.ac: Add AM_CONDITIONAL for enable_multilib, enable_posix, enable_itron. * Makefile.am: Compute MULTISUBDIR on-the-fly. Conditionally add libposix and libitron to SRCS. Apply MULTISUBDIR for picking up librtems, libposix and libitron.
Diffstat (limited to '')
-rw-r--r--c/src/wrapup/configure.ac4
1 files changed, 4 insertions, 0 deletions
diff --git a/c/src/wrapup/configure.ac b/c/src/wrapup/configure.ac
index 8f4c1b2c43..4a4fe568b8 100644
--- a/c/src/wrapup/configure.ac
+++ b/c/src/wrapup/configure.ac
@@ -36,6 +36,10 @@ RTEMS_PROJECT_ROOT
RTEMS_PROG_CC_FOR_TARGET
RTEMS_CANONICALIZE_TOOLS
+AM_CONDITIONAL([MULTILIB],[test x"$enable_multilib" = x"yes"])
+AM_CONDITIONAL([HAS_POSIX],[test x"$enable_posix" = x"yes"])
+AM_CONDITIONAL([HAS_ITRON],[test x"$enable_itron" = x"yes"])
+
# Explicitly list all Makefiles here
AC_CONFIG_FILES([Makefile
])