summaryrefslogtreecommitdiffstats
path: root/c/src/wrapup/configure.ac
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2002-03-15 13:58:29 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2002-03-15 13:58:29 +0000
commit082972afe787c8c98e3a5aad1cb342fdf696341a (patch)
treeb441c7a7998be96e21aa8b876a5355bca5e3940b /c/src/wrapup/configure.ac
parent2002-03-15 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-082972afe787c8c98e3a5aad1cb342fdf696341a.tar.bz2
2002-03-15 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.ac: Special treatment of the bare BSP. Add RTEMS_BSP_ALIAS. Add HAS_LIBBSP. * Makefile.am: Append libbsp.a to SRC conditionally.
Diffstat (limited to '')
-rw-r--r--c/src/wrapup/configure.ac5
1 files changed, 5 insertions, 0 deletions
diff --git a/c/src/wrapup/configure.ac b/c/src/wrapup/configure.ac
index 453bb81e8a..633eabfc2d 100644
--- a/c/src/wrapup/configure.ac
+++ b/c/src/wrapup/configure.ac
@@ -21,6 +21,11 @@ RTEMS_ENABLE_MULTILIB
RTEMS_ENV_RTEMSBSP
RTEMS_CHECK_CPU
RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
+RTEMS_BSP_ALIAS(${RTEMS_BSP},bspalias)
+
+# The bare bsp doesn't have libbsp.a
+# FIXME: We should use a feature based check, here
+AM_CONDITIONAL(HAS_LIBBSP,[! test "$bspalias" = "bare"])
RTEMS_CHECK_NETWORKING(RTEMS_BSP)
if test "$HAS_NETWORKING" = "yes"; then