summaryrefslogtreecommitdiffstats
path: root/c/src/wrapup/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2004-01-27 01:38:49 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2004-01-27 01:38:49 +0000
commit171a04c4df5a3d32c90d77d4f554251651edf12c (patch)
tree8e9444b3999db89d36cf1a518803ae0cd6f19572 /c/src/wrapup/Makefile.am
parent2004-01-26 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-171a04c4df5a3d32c90d77d4f554251651edf12c.tar.bz2
2004-01-27 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* configure.ac: Add AM_CONDITIONAL HAS_WRAPUP_LIBBSP. * wrapup/Makefile.am: Add AM_CONDITIONAL HAS_WRAPUP_LIBBSP.
Diffstat (limited to 'c/src/wrapup/Makefile.am')
-rw-r--r--c/src/wrapup/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/c/src/wrapup/Makefile.am b/c/src/wrapup/Makefile.am
index ab5050089a..87b0a764a4 100644
--- a/c/src/wrapup/Makefile.am
+++ b/c/src/wrapup/Makefile.am
@@ -12,8 +12,13 @@ project_lib_DATA = $(ARCH)/librtemsbsp$(LIB_VARIANT).a
SRCS = ../support/libsupport$(LIB_VARIANT).a
if HAS_LIBBSP
+if HAS_WRAPUP_LIBBSP
SRCS += \
../lib/libbsp/@RTEMS_CPU@/@RTEMS_BSP_FAMILY@/wrapup/$(ARCH)/libbsp.a
+else
+SRCS += \
+ ../lib/libbsp/@RTEMS_CPU@/@RTEMS_BSP_FAMILY@/libbsp$(LIB_VARIANT).a
+endif
endif
if HAS_NETWORKING