summaryrefslogtreecommitdiffstats
path: root/c/src/tests/support/include/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-12 15:00:15 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2000-06-12 15:00:15 +0000
commitdf49c60c9671e4a28e636964d744c1f59fb6cb68 (patch)
treeeabd85e189514ad412a35414ba5d483dcda3ef1f /c/src/tests/support/include/Makefile.am
parentPurged as many egcs references as possible. (diff)
downloadrtems-df49c60c9671e4a28e636964d744c1f59fb6cb68.tar.bz2
Merged from 4.5.0-beta3a
Diffstat (limited to 'c/src/tests/support/include/Makefile.am')
-rw-r--r--c/src/tests/support/include/Makefile.am18
1 files changed, 6 insertions, 12 deletions
diff --git a/c/src/tests/support/include/Makefile.am b/c/src/tests/support/include/Makefile.am
index 72f0f3c837..d5d258b558 100644
--- a/c/src/tests/support/include/Makefile.am
+++ b/c/src/tests/support/include/Makefile.am
@@ -4,26 +4,20 @@
AUTOMAKE_OPTIONS = foreign 1.4
-project_bspdir=$(PROJECT_ROOT)/@RTEMS_BSP@
+project_bspdir = $(PROJECT_ROOT)/@RTEMS_BSP@
noinst_HEADERS = tmacros.h
-TMPINSTALLDIRS=$(project_bspdir)/lib/include
+TMPINSTALLFILES = $(project_bspdir)/lib/include \
+ $(project_bspdir)/lib/include/tmacros.h
-$(TMPINSTALLDIRS):
+$(project_bspdir)/lib/include:
$(mkinstalldirs) $@
-
-TMPINSTALLFILES = $(project_bspdir)/lib/include/tmacros.h
-
$(project_bspdir)/lib/include/tmacros.h: tmacros.h
$(INSTALL_DATA) $< $@
-CLEANFILES = $(TMPINSTALLFILES)
-
-install-tmp: $(TMPINSTALLFILES)
+CLEANFILES = $(project_bspdir)/lib/include/tmacros.h
-all: install-tmp
-debug: install-tmp
-profile: install-tmp
+all-local: $(TMPINSTALLFILES)
include $(top_srcdir)/../../../../automake/local.am