summaryrefslogtreecommitdiffstats
path: root/c/src/tests/support/include/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2002-08-02 00:51:52 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2002-08-02 00:51:52 +0000
commitcd9396e7d084473bee312f6e1cda13174247e0cc (patch)
tree2c9aa9ecac285af73fadd342172538296d806e5e /c/src/tests/support/include/Makefile.am
parent2002-08-01 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-cd9396e7d084473bee312f6e1cda13174247e0cc.tar.bz2
2002-08-01 Joel Sherrill <joel@OARcorp.com>
* Per PR47 add support for buffered test output. This involved adding defines to redirect output to a buffer and dump it when full, at "test pause", and at exit. To avoid problems when redefining exit(), all tests were modified to call rtems_test_exit(). Some tests, notable psxtests, had to be modified to include the standard test macro .h file (pmacros.h or tmacros.h) to enable this support. * include/buffer_test_io.h: New file.
Diffstat (limited to 'c/src/tests/support/include/Makefile.am')
-rw-r--r--c/src/tests/support/include/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/c/src/tests/support/include/Makefile.am b/c/src/tests/support/include/Makefile.am
index ebbdc7bc99..6d031fcb3b 100644
--- a/c/src/tests/support/include/Makefile.am
+++ b/c/src/tests/support/include/Makefile.am
@@ -8,14 +8,18 @@ project_bspdir = $(PROJECT_ROOT)/@RTEMS_BSP@
noinst_HEADERS = tmacros.h
TMPINSTALLFILES = $(project_bspdir)/lib/include \
- $(project_bspdir)/lib/include/tmacros.h
+ $(project_bspdir)/lib/include/tmacros.h \
+ $(project_bspdir)/lib/include/buffer_test_io.h
$(project_bspdir)/lib/include:
$(mkinstalldirs) $@
$(project_bspdir)/lib/include/tmacros.h: tmacros.h
$(INSTALL_DATA) $< $@
+$(project_bspdir)/lib/include/buffer_test_io.h: buffer_test_io.h
+ $(INSTALL_DATA) $< $@
-CLEANFILES = $(project_bspdir)/lib/include/tmacros.h
+CLEANFILES = $(project_bspdir)/lib/include/tmacros.h \
+ $(project_bspdir)/lib/include/buffer_test_io.h
all-local: $(TMPINSTALLFILES)