summaryrefslogtreecommitdiffstats
path: root/c/src/tests/support/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2002-08-21 10:04:45 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2002-08-21 10:04:45 +0000
commit304cdca20697caf6e7fcfe003e3a9dfcc5baec9a (patch)
tree1e07c281d936a970e26d04c79f4391cd5adbc812 /c/src/tests/support/Makefile.am
parent2002-08-20 Ralf Corsepius <corsepiu@faw.uni-ulm.de> (diff)
downloadrtems-304cdca20697caf6e7fcfe003e3a9dfcc5baec9a.tar.bz2
2002-08-21 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
* include/Makefile.am: Remove. * Makefile.am: Merge in former include/Makefile.am. * configure.ac: Reflect changes above. Take out unnecessary autoconf macros.
Diffstat (limited to 'c/src/tests/support/Makefile.am')
-rw-r--r--c/src/tests/support/Makefile.am19
1 files changed, 17 insertions, 2 deletions
diff --git a/c/src/tests/support/Makefile.am b/c/src/tests/support/Makefile.am
index bb79a6c15c..0cd6acdc57 100644
--- a/c/src/tests/support/Makefile.am
+++ b/c/src/tests/support/Makefile.am
@@ -4,7 +4,22 @@
ACLOCAL_AMFLAGS = -I ../../../../aclocal
-SUBDIRS = include
+project_bspdir = $(PROJECT_ROOT)/@RTEMS_BSP@
+
+noinst_HEADERS = include/tmacros.h include/buffer_test_io.h
+
+TMPINSTALLFILES = $(project_bspdir)/lib/include \
+ $(project_bspdir)/lib/include/tmacros.h \
+ $(project_bspdir)/lib/include/buffer_test_io.h
+
+$(project_bspdir)/lib/include:
+ $(mkinstalldirs) $@
+$(project_bspdir)/lib/include/%.h: include/%.h
+ $(INSTALL_DATA) $< $@
+
+CLEANFILES = $(project_bspdir)/lib/include/tmacros.h \
+ $(project_bspdir)/lib/include/buffer_test_io.h
+
+all-local: $(TMPINSTALLFILES)
-include $(top_srcdir)/../../../../automake/subdirs.am
include $(top_srcdir)/../../../../automake/local.am