summaryrefslogtreecommitdiffstats
path: root/c/src/tests/sptests/sp32/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>2002-09-14 18:47:07 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>2002-09-14 18:47:07 +0000
commit0af7c204341e66d6004aa14ba9a84fef87675664 (patch)
treeff1515634a8ac7880232bc528f62dade9abf3244 /c/src/tests/sptests/sp32/Makefile.am
parent2002-09-14 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-0af7c204341e66d6004aa14ba9a84fef87675664.tar.bz2
2002-09-14 Aaron J. Grier <aaron@frye.com>
* PR271 was not applicable against the current source but included a nice test that Joel decided to add to the tree as sp32. * sp32/Makefile.am, sp32/init.c, sp32/sp32.scn: New file. * Makefile.am, configure.ac: Modified to reflect addition.
Diffstat (limited to 'c/src/tests/sptests/sp32/Makefile.am')
-rw-r--r--c/src/tests/sptests/sp32/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/c/src/tests/sptests/sp32/Makefile.am b/c/src/tests/sptests/sp32/Makefile.am
new file mode 100644
index 0000000000..fa23bd8494
--- /dev/null
+++ b/c/src/tests/sptests/sp32/Makefile.am
@@ -0,0 +1,34 @@
+##
+## $Id$
+##
+
+TEST = sp32
+
+MANAGERS = io rate_monotonic
+
+C_FILES = init.c
+C_O_FILES = $(C_FILES:%.c=${ARCH}/%.$(OBJEXT))
+
+DOCTYPES = scn
+DOCS = $(DOCTYPES:%=$(TEST).%)
+
+SRCS = $(C_FILES) $(H_FILES)
+OBJS = $(C_O_FILES)
+
+PRINT_SRCS = $(DOCS)
+
+PGM = ${ARCH}/$(TEST).exe
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../automake/compile.am
+include $(top_srcdir)/../../../../automake/leaf.am
+include $(top_srcdir)/sptests.am
+
+${PGM}: $(OBJS) $(LINK_FILES)
+ $(make-exe)
+
+all-local: $(ARCH) $(TMPINSTALL_FILES)
+
+EXTRA_DIST = $(C_FILES) $(DOCS)
+
+include $(top_srcdir)/../../../../automake/local.am