summaryrefslogtreecommitdiffstats
path: root/c/src/tests/sptests/sp02/Makefile.am
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-11-22 19:08:23 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-11-22 19:08:23 +0000
commit5fe4a10911353b723b86d11486683eb9238516b5 (patch)
tree6b4d081a727e68535086aa4e4de4e2c7cc8f382b /c/src/tests/sptests/sp02/Makefile.am
parentNow replaced by an automake file. (diff)
downloadrtems-5fe4a10911353b723b86d11486683eb9238516b5.tar.bz2
Converted to automake.
Diffstat (limited to '')
-rw-r--r--c/src/tests/sptests/sp02/Makefile.am40
1 files changed, 40 insertions, 0 deletions
diff --git a/c/src/tests/sptests/sp02/Makefile.am b/c/src/tests/sptests/sp02/Makefile.am
new file mode 100644
index 0000000000..fcbcb7864f
--- /dev/null
+++ b/c/src/tests/sptests/sp02/Makefile.am
@@ -0,0 +1,40 @@
+##
+## $Id$
+##
+
+AUTOMAKE_OPTIONS = foreign 1.4
+ACLOCAL_AMFLAGS = -I $(RTEMS_TOPdir)/aclocal
+
+TEST = sp02
+
+MANAGERS = io
+
+# C source names, if any, go here -- minus the .c
+C_FILES = init.c task1.c task2.c task3.c preempt.c
+C_O_FILES = $(C_FILES:%.c=${ARCH}/%.o)
+
+H_FILES = system.h
+noinst_HEADERS =$(H_FILES)
+
+DOCTYPES = scn doc
+DOCS = $(DOCTYPES:%=$(TEST).%)
+
+SRCS = $(C_FILES) $(H_FILES)
+OBJS = $(C_O_FILES)
+
+PRINT_SRCS = $(DOCS)
+
+PGM = ${ARCH}/$(TEST).exe
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(RTEMS_ROOT)/make/leaf.cfg
+include $(top_srcdir)/sptests.am
+
+${PGM}: $(OBJS) $(LINK_FILES)
+ $(make-exe)
+
+all-local: $(ARCH) $(TMPINSTALL_FILES)
+
+EXTRA_DIST = $(C_FILES) $(DOCS)
+
+include $(top_srcdir)/../../../../automake/local.am