summaryrefslogtreecommitdiffstats
path: root/c/src/tests/samples/pppd/Makefile.am
diff options
context:
space:
mode:
authorRalf Corsepius <ralf.corsepius@rtems.org>2003-04-29 02:04:26 +0000
committerRalf Corsepius <ralf.corsepius@rtems.org>2003-04-29 02:04:26 +0000
commit478bb1e63d1ddecd7579a0628f3f54cc4f5afa7f (patch)
tree4ee5bb16317d68971808b4758b796cfc53338395 /c/src/tests/samples/pppd/Makefile.am
parent2003-04-18 Joel Sherrill <joel@OARcorp.com> (diff)
downloadrtems-478bb1e63d1ddecd7579a0628f3f54cc4f5afa7f.tar.bz2
2003-04-29 Ralf Corsepius <corsepiu@faw.uni-ulm.de>
Adding pppd: * pppd/Makefile-user: New, copied over from libnetworking/pppd/example. * pppd/README: New, copied over from libnetworking/pppd/example. * pppd/init.c: New, copied over from libnetworking/pppd/example. * pppd/netconfig.h: New, copied over from libnetworking/pppd/example. * pppd/ppp.conf: New, copied over from libnetworking/pppd/example. * pppd/pppdapp.c: New, copied over from libnetworking/pppd/example. * pppd/system.h: New, copied over from libnetworking/pppd/example. * pppd/pppd.options: New, copied over from libnetworking/pppd/example. * pppd/Makefile.am: New, converted to automake from Makefile-user. * pppd/.cvsignore: New.
Diffstat (limited to 'c/src/tests/samples/pppd/Makefile.am')
-rw-r--r--c/src/tests/samples/pppd/Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/c/src/tests/samples/pppd/Makefile.am b/c/src/tests/samples/pppd/Makefile.am
new file mode 100644
index 0000000000..7e429e499d
--- /dev/null
+++ b/c/src/tests/samples/pppd/Makefile.am
@@ -0,0 +1,43 @@
+##
+## $Id$
+##
+
+
+SAMPLE = pppd
+PGM = ${ARCH}/$(SAMPLE).exe
+
+MANAGERS = io event semaphore
+
+C_FILES = init.c pppdapp.c
+C_O_FILES = $(C_FILES:%.c=${ARCH}/%.$(OBJEXT))
+
+H_FILES = netconfig.h system.h
+
+DOCTYPES = scn
+DOCS = $(DOCTYPES:%=$(SAMPLE).%)
+
+SRCS = $(DOCS) $(C_FILES) $(H_FILES)
+OBJS = $(C_O_FILES)
+
+PRINT_SRCS = $(DOCS)
+
+include $(RTEMS_ROOT)/make/custom/@RTEMS_BSP@.cfg
+include $(top_srcdir)/../../../../automake/compile.am
+include $(top_srcdir)/../../../../automake/leaf.am
+include $(top_srcdir)/sample.am
+
+#
+# (OPTIONAL) Add local stuff here using +=
+#
+
+
+if HAS_NETWORKING
+all-local: ${ARCH} $(TMPINSTALL_FILES)
+
+${PGM}: $(OBJS) $(LINK_FILES)
+ $(make-exe)
+endif
+
+EXTRA_DIST = $(C_FILES) $(H_FILES) $(DOCS)
+
+include $(top_srcdir)/../../../../automake/local.am