summaryrefslogtreecommitdiffstats
path: root/c/src/tests/configure.in
diff options
context:
space:
mode:
authorJoel Sherrill <joel.sherrill@OARcorp.com>1999-07-30 17:52:50 +0000
committerJoel Sherrill <joel.sherrill@OARcorp.com>1999-07-30 17:52:50 +0000
commit1896a650fc382d343844b56f4b79efe31562755e (patch)
tree922de4dd1237cfcf6c7be0a8050e1e964fceadad /c/src/tests/configure.in
parentFixed typos. (diff)
downloadrtems-1896a650fc382d343844b56f4b79efe31562755e.tar.bz2
Patch from Ralf Corsepius <corsepiu@faw.uni-ulm.de>:
The main topic is replacing the hard-coded values for HAS_MP and HAS_RDBG in custom/*.cfg with per-bsp configuration-time autoconf checks (This is the patch I had mentioned before earlier this week). CHANGES * HAS_MP removed from custom/*.cfg, replaced with configuration time autoconf check * HAS_RDBG removed from custom/*.cfg, replaced with configuration-time autoconf check * NEW: c/src/make/bsp.cfg.in, takes configuration-time checked per-bsp values (i.e. HAS_MP, HAS_RDBG), gets installed as $(prefix)/<bsp>/make/bsp.cfg * NEW: default.cfg includes bsp.cfg - this change is backward compatible. * IMPORT_SRC: apply VPATH instead for ts_386ex/i386ex subdirectory Makefile.ins * HACK: a bug in acpolish mis-handles addtions to makefile variables which are enclosed in gmake conditionals: c/src/lib/libbsp/m68k/ods68302/start302/Makefile.in * Apply inline_dir, HAS_MP and HAS_RDBG for avoiding configuration of unneeded subdirectories in various configure.in files. * Several minor changes in Makefile.ins and configure.ins, wrt. to the order of including *.cfg and defining Makefile variables APPLYING THE PATCH: patch -p1 < rtems-rc-19990709-4.diff ./autogen
Diffstat (limited to '')
-rw-r--r--c/src/tests/configure.in31
1 files changed, 18 insertions, 13 deletions
diff --git a/c/src/tests/configure.in b/c/src/tests/configure.in
index a1a6d9a818..78e9b685a9 100644
--- a/c/src/tests/configure.in
+++ b/c/src/tests/configure.in
@@ -28,7 +28,6 @@ RTEMS_ENV_RTEMSBSP
dnl BEGIN configure.host.in
-AC_PATH_PROG(RM,rm)
AC_PROG_INSTALL
dnl BEGIN configure.target.in
@@ -54,19 +53,28 @@ RTEMS_I386_GAS_CODE16
RTEMS_CHECK_SYSV_UNIX
RTEMS_CHECK_CUSTOM_BSP(RTEMS_BSP)
+RTEMS_CHECK_MULTIPROCESSING(RTEMS_BSP)
# always build the test tools
testtools_cfgdirs="tools/generic"
+
+if test "$HAS_MP" = "yes"; then
+ makefiles="$makefiles samples/base_mp/Makefile"
+ makefiles="$makefiles samples/base_mp/node1/Makefile"
+ makefiles="$makefiles samples/base_mp/node2/Makefile"
+ makefiles="$makefiles samples/base_sp/Makefile"
+fi
+
if test "$tests_enabled" = "yes"; then
- RTEMS_CHECK_MAKEFILE(libtests)
- RTEMS_CHECK_MAKEFILE(sptests)
- RTEMS_CHECK_MAKEFILE(tmtests)
- if test "$RTEMS_HAS_MULTIPROCESSING" = "yes"; then
- RTEMS_CHECK_MAKEFILE(mptests)
- fi
- if test "$RTEMS_HAS_POSIX_API" = "yes"; then
- RTEMS_CHECK_MAKEFILE(psxtests)
- fi
+ RTEMS_CHECK_MAKEFILE(libtests)
+ RTEMS_CHECK_MAKEFILE(sptests)
+ RTEMS_CHECK_MAKEFILE(tmtests)
+ if test "$HAS_MP" = "yes"; then
+ RTEMS_CHECK_MAKEFILE(mptests)
+ fi
+ if test "$RTEMS_HAS_POSIX_API" = "yes"; then
+ RTEMS_CHECK_MAKEFILE(psxtests)
+ fi
if test -d "$srcdir/tools/$RTEMS_CPU"; then
testtools_cfgdirs="$testtools_cfgdirs tools/$RTEMS_CPU"
fi
@@ -94,9 +102,6 @@ support/stubdr/Makefile
support/wrapup/Makefile
tools/Makefile
samples/Makefile
-samples/base_mp/Makefile
-samples/base_mp/node1/Makefile
-samples/base_mp/node2/Makefile
samples/base_sp/Makefile
samples/cdtest/Makefile
samples/hello/Makefile